Issues Compiling Dahdi; Centos 7; TDM800P

I’m trying to compile dahdi on my system and having some problems - my TDM800P w/hardware EC isn’t correctly recognized.

I’ve tried Digium Support, but they respond that the product is out of warranty, too bad for me.

The board works correctly under its ‘current’ install/same machine under dahdi 2.9

When I compile 3.0, I get a warning about vpm (something), but it is gone too fast; but I get the message that dahdi has compiled correctly. When I run make install-config, I get:

WARNING: could not find /usr/src/dahdi-linux-complete-3.0.0+3.0.0/linux/drivers/dahdi/vpmadt032_loader/.vpmadt032_x86_64.o.cmd for /usr/src/dahdi-linux-complete-3.0.0+3.0.0/linux/drivers/dahdi/vpmadt032_loader/vpmadt032_x86_64.o
which I believe is the crux of the problem (since this is the HW EC).

If I run service dahdi restart, I get:
service dahdi restart
Unloading DAHDI hardware modules: done
Loading DAHDI hardware modules:

/usr/sbin/dahdi_span_assignments: Missing ‘/etc/dahdi/assigned-spans.conf’
Running dahdi_cfg: /usr/sbin/dahdi_cfg: error while loading shared libraries: cannot open shared object file: No such file or directory

This is being attempted under Centos 7.

I have tried various iterations of make clean, make, make install, etc, - same issue.
dahdi_hardware shows the ‘Wildcard’, but with a “-” next to vctdm24xxp (ie driver not loaded).

Any thoughts?


The warning is fine.

DAHDI 3.0 removed driver support for a number of our end of life cards, including the TDM800. You’ll need to stick to DAHDI 2.9.x for that card.

1 Like

What a great, prompt reply. Thanks

2 Questions:

Will I need to downgrade Asterisk or recompile? I’m using 13.24
Will I need to downgrade libpri or recompile? I’m using 1.6



You’ll want to rebuild Asterisk after building and installing DAHDI 2.9.x, yes.
For the TDM800, libpri isn’t used, so that shouldn’t be any issue.

1 Like

When I recompile asterisk 13.24.1 (no changes from prior setup), and do ‘asterisk -vvvvr’
show dahdi channels comes back with an error.

when I go into the asterisk source directory and issue ‘make menuselect’,
under Channel drivers, chan_dahdi is XXX’d out. Under details, it says it requires
dahdi (E), timezone (E).

dahdi 2.9.2 is running correctly, my board is recognized, hardware EC is recognized.

Clearly asterisk doesn’t recognize .

How do I get asterisk to recompile with dahdi support for 2.9.2?

Thanks all.