Issue while compiling Asterisk Software

Hello All !!! Happy New Year !!!

Please help me with that issue:
I am using UBUNTU 14.0

Both DAHDI and Libpri have been installed as well as Aterisk software,
when i finished to compile DAHDI and Libpri, so now it is time for Asterisk :

This command does not work cd ~/src/asterisk-complete/asterisk/11 i got this following error :
No such file or directory

Try This one cd ~/src/asterisk-complete/asterisk*,it works

But i still cannot compile Asterisk whit that following line : ./configure i got this error :
No such file or directory

Please help me to fix this issue !

I am using the Definitive Guide Book

Look Forward to your reply.

Thanks !

“cd” to the extracted directory where you downloaded the tarball of asterisk. Try to not copy and paste commands but understand what the commands does.

You do not compile AsteriskNOW; it is for people who want to install Asterisk without even a basic understanding of Linux/Unix and who have probably never compiled a program in their life. You want Asterisk Support if you are building from source (or writing your own configurations).

Assuming Asterisk 11 has the same tarball structure as previous versions, you would expect the directory containing the source tree to be immediately below the current directory and named asterisk-. I’ve just downloaded it and looked. It does follow that convention. It should extract to asterisk-11.2.0 in the current directory and you should change to asterisk-11.2.0 and run the build commands from there.

Where did you get the tarball from and how did you extract it? Where did you get the build instructions from?

Thank you @navaismo and @david :

I 've get the asterisk software version from the source issue with that command :

This is the steps i 've followed :
cd ~/src/asterisk-complete/asterisk
$ wget … ent.tar.gz
$ tar zxvf asterisk-11-current.tar.gz (To Unziped)

I get the build isntructions from the: The Definitive Guide, 4th Edition book !
I have copied some lines of the documents here :

Step 1
Getting the Source via wget
To obtain the latest released versions of DAHDI, LibPRI, and Asterisk using the wget
application, issue the following commands:

$ cd ~/src/asterisk-complete/asterisk
$ wget … ent.tar.gz
$ tar zxvf asterisk-11-current.tar.gz
$ wget … ent.tar.gz
$ tar zxvf libpri-1.4-current.tar.gz
$ wget … -complete/
$ tar zxvf dahdi-linux-complete.tar.gz

Step 2 :

With both DAHDI and LibPRI installed, we can now install Asterisk:
$ cd ~/src/asterisk-complete/asterisk/11

If you are running 64-bit RHEL, run the configure script with the libdir option:
$ ./configure --libdir=/usr/lib64
On any other platform, run the configure script without any arguments:
$ ./configure
Finally, compile and install Asterisk:
$ make
$ sudo make install
$ sudo make config

Thanks !

Assuming the instructions are the same as for version 3 of the book, they assume that you have created the directories mentioned and you have populated them using svn, rather than the downloaded tar balls.

Okay thanks !

Althought, DHADI and LibPRI do not give that problem,

Could you please point me the right command to get Asterisk compiling.

Thanks !

The commands are:

make menuselect <-- to choose wht to compile
make install
make samples <— for new installations

But your issue is about the directory. You need to find which dir has the asterisk sources first!

Reading between the lines, I think he has downloaded the tar balls and then not used them. Dahdi worked because the latest versions are in SVN, but he will not be able to do an SVN install for the latest branch 11 version, because the developers now use GIT. I guess he just didn’t understand that he had received an error when he tried to do the svn checkout.

The install instructions from once you have extracted the tar balls are in the README file in the first level extracted directory.

Note that the only slightly non-standard things about the whole process, from tar balls, are the make menuconfig and make samples steps.

As it occurs to me that he might not even have done the extract step but rather tried to use SVN for everything and not seen the error message, see … mand-line/

Thank You Both !

I have try this line of command :

cd ~/src/asterisk-complete/asterisk/ (With no version)
$ mkdir asterisk
$ cd asterisk/
$ svn co (With no version)

It 's about compiling now, i will see the result when it done.

Thanks !

That svn command will download every svn version, including betas and release candidates, ever released, up to the point when they switched to git!!!

You need to extract the tar ball, rather than running svn.

Thank you,

Will do now .

Thanks !

I think i did it yet after downloaded Asterisk Software using this following command :

$ tar zxvf asterisk-11-current.tar.gz

Is that what you talked about ??

Thanks !

The tar command extracts it, assuming you have already downloaded it.

You should not do both extract the tar and used svn.

There should only be one new directory visible in the current directory after running that tar command. cd in that and follow the instructions starting at ./configure.

(If you have run the svn, you will have several GB of files to remove first!)

Thanks !

Thank you very much @david,

The problem is fix now !

Great !!! i see the Asterisk log on the screen .

Thanks !