not building on asterisk-

I am trying to install asterisk- and configure a Wildcard TDM800P.
Linux is RHEL 5
After installing libpri and dahdi-linux, dahdi-tools (using yum) and restarting. I built asterisk, and it is running fine.

But I see that it has not build

ls /usr/lib/asterisk/modules/

ls: /usr/lib/asterisk/modules/ No such file or directory

Asterisk CLI
localhost*CLI> load
No such command ‘load’ (type ‘core show help load’ for other possible commands)

I see that the drivers are installed fine …
Below are the details of my installation …

rpm -qa | grep libpri


rpm -qa | grep dahdi



lsmod | grep dahdi

dahdi_echocan_mg2 10248 0
dahdi_transcode 12164 1 wctc4xxp
dahdi_voicebus 45120 2 wctdm24xxp,wcte12xp
dahdi 196168 12 dahdi_echocan_mg2,xpp,dahdi_transcode,wcb4xxp,wctdm,wcfxo,wctdm24xxp,wcte11xp,wct1xxp,wcte12xp,dahdi_voicebus,wct4xxp
crc_ccitt 6337 2 wctdm24xxp,dahdi

I have run the make samples on asterisk whivch creates the chan_dahdi.conf default.
and I have the default /etc/dahdi/system.conf with channels as follows

dahdi_cfg -vv

DAHDI Tools Version - 2.3.0

DAHDI Version: 2.3.0
Echo Canceller(s): MG2

Channel map:

Channel 01: FXO Kewlstart (Default) (Echo Canceler: mg2) (Slaves: 01)
Channel 02: FXO Kewlstart (Default) (Echo Canceler: mg2) (Slaves: 02)
Channel 05: FXS Kewlstart (Default) (Echo Canceler: mg2) (Slaves: 05)
Channel 06: FXS Kewlstart (Default) (Echo Canceler: mg2) (Slaves: 06)

4 channels to configure.

Setting echocan for channel 1 to mg2
Setting echocan for channel 2 to mg2
Setting echocan for channel 5 to mg2
Setting echocan for channel 6 to mg2


you can manually copy the file to modules.

thanks James… that worked for me.

now the next problm seems to be a config issue. I’ve installed all dahdi drivers and no zaptel. (with yum)

when i run the asterisk, the log gives me this error
^[[1;30;40m == ^[[0;37;40mParsing ‘/etc/asterisk/zapata.conf’: Found
^[[1;30;40m == ^[[0;37;40mParsing ‘/etc/asterisk/zapata_motogate.conf’: Found
[Apr 27 18:55:52] ^[[1;31;40mWARNING^[[0;37;40m[3527]: ^[[1;37;40mchan_dahdi.c^[[0;37;40m:^[[1;37;40m1231^[[0;37;40m ^[[1;37;40mdahdi_open^[[0;37;40m: Unable to open ‘/dev/zap/channel’: No such file or directory
[Apr 27 18:55:52] ^[[31;40mERROR^[[0;37;40m[3527]: ^[[1;37;40mchan_dahdi.c^[[0;37;40m:^[[1;37;40m7720^[[0;37;40m ^[[1;37;40mmkintf^[[0;37;40m: Unable to open channel 1: No such file or directory
here = 0, tmp->channel = 1, channel = 1
[Apr 27 18:55:52] ^[[31;40mERROR^[[0;37;40m[3527]: ^[[1;37;40mchan_dahdi.c^[[0;37;40m:^[[1;37;40m11378^[[0;37;40m ^[[1;37;40mbuild_channels^[[0;37;40m: Unable to register channel ‘1’

now since i’l loaded all dahdi drivers, and also set the dahdichanname = yes in asterisk.conf, is it not supposed to look for /dev/dahdi/channel ?

[root@localhost dev]# ls /dev/dahdi/
1 2 3 4 5 6 7 8 channel ctl pseudo timer transcode

I tried renaming the folder dahdi with zap, but that fails something else, also tried making a soft link ln -s dahdi zap

or am i missing something ?
asterisk itself is otherwise up and running.


check this:

40mdahdi_open^[[0;37;40m: Unable to open ‘/dev/zap/channel’: No such file or directory

i think there are some softlinks wrong or please change this:
/etc/asterisk/asterisk.conf file:
dahdichanname = no

thanks for the reply james. I have currently fallen back on asterisk 1.2 as I had to bring up an asterisk system on priority.
I will get back to this again once I’m done with my req.

thanks a lot for the time …