Issue using menuselect.makeopts on Asterisk 13.8

Hi All,

Firstly let me say I am fairly new to Asterisk, but I’ve been playing with it in its simplest forms for a year or so and am now trying to delve in a little deeper. The issue I am having is around the ‘menuselect.makeopts’ function using Asterisk 13.8-Cert3.

  1. When running this, I get the following message when I enter something like: -
    menuselect/menuselect --enable format_mp3 menuselect.makeopts.

Message =
Unknown value ‘’ found in build_tools/menuselect-deps for HAVE_LEAK_SANITIZER
Unknown value ‘’ found in build_tools/menuselect-deps for HAVE_UNDEFINED_SANITIZER

I’ve looked around the forum and found some other instances of this, but these were in earlier releases.

  1. When i run the command menuselect/menuselect --list-options before and after I’ve attempt to make changes, this output is always the same. Maybe I am missing something here, but I would have thought that this list would reflect the changes I’ve made using the menuselect.makeopts. Even if I run make menuselect and use the menus to make changes, when I come out and then run the list options, nothing has changed.

Please, can someone enlighten me in what I missing?

If it makes any difference, this is running on a clean install of Ubuntu 14.04.1

Thanks is advance for you assistance.


It’s actually a harmless message. When ./configure runs it updates build_tools/menuselect-deps with the capabilities it discovered. menuselect then uses that file to allow/disallow certain menuselect options. In this case your compiler doesn’t support the “leak” or “undefined” sanitizers. There’s nothing wrong with that but ./configure should be setting those values to ‘0’ instead leaving them blank. You may occasionally see those messages for NATIVE_ARCH as well, and especially if you change versions in the same directory. We should fix ./ Someday. :slight_smile:

1 Like

Thanks for the reply gjoseph. That explains the build_tools/menuselect-depsmessage when I run the menuselect.makeopts command.

Do you know why this command doesn’t appear to be having any affect on the --list-options? Am I doing something silly?

Many thanks

Oh, sorry. I completely missed your second question.

–list-options lists all the possible options and their categories, not the ones you’ve selected. If you want to see the result of what you’ve selected, look at the menuselect.makeopts file. The MENUSELECT_ADDONS, APPS, BRIDGES, CDR, CEL, CHANNELS, CODECS, FORMATS, FUNCS, PBX, RES and TESTS categories all list the modules you’ve NOT selected. They’ll be EXCLUDED from the build. The rest of the categories list options you HAVE selected.
This file is included by all the makefiles and controls what gets built and how.

Thanks again for your assistance gjoseph

That helps. :slight_smile: