Issue : Disaplay CallerID on OutBound Calls


I have installed asterisk- and my setup is working fine.

I m having 1 PRI line having number 5150100. and its having 100 pilot numbers (from 5150100 to 5150200). I have my call center application running properly.
Query : when I make the out bound calls from the soft phone it shows the pilot number of my PRI (i,e first pilot number - 5150100). But I want to display some other number(5150111) to the customers screen.

CallerID display is activated from the PRI service provider. But still I can’t set my own callerID number for the outbound calls. How can I set my own number for outbound calls ?

Any help is highly appreciated.


Security fixes ceased on 1.6.0.x almost two years ago and general bug fixes ceased almost 3 years ago.

You need to talk to your service provider.

Asterisk will try to send caller ID end to end, but you may need to use the CALLERID function to manipulate and and set things like type of number, and you may have to arrange with your service provider as to which ranges of caller ID number they will trust from you.

Thank you david for your quick help.

I have tried to set the callerID as bellow :

But the above is not setting the callerID number.


Talk to your service provider. Either then type of number is wrong, or you are not using a number that they will allow you to use.