ISDN PRI not getting Sync


#1

Dear All,

We are trying to intall a digium TE110P and make it work with Asterisk. The contents of both relevant files and output of common commands are appended. The problem is that the E1 ISDN PRI line from the telco is not getting sync with the card. The protocol on the line if Euro ISDN (India, CRC ON). Please help.


Version Information

Cent OS 3.5, Kernel ver 2.4.21-32.EL
Asterisk 1.2.7.1
Zaptel 1.2.5
libpri 1.2.2
gcc 3.2.3 20030502 (Red Hat Linux 3.2.3-52)


ztcfg -vv output

SPAN 1: CCS/HDB3 Build-out: 0 db (CSU)/0-133 feet (DSX-1)

Channel map:

Channel 01: Clear channel (Default) (Slaves: 01)
Channel 02: Clear channel (Default) (Slaves: 02)
Channel 03: Clear channel (Default) (Slaves: 03)
Channel 04: Clear channel (Default) (Slaves: 04)
Channel 05: Clear channel (Default) (Slaves: 05)
Channel 06: Clear channel (Default) (Slaves: 06)
Channel 07: Clear channel (Default) (Slaves: 07)
Channel 08: Clear channel (Default) (Slaves: 08)
Channel 09: Clear channel (Default) (Slaves: 09)
Channel 10: Clear channel (Default) (Slaves: 10)
Channel 11: Clear channel (Default) (Slaves: 11)
Channel 12: Clear channel (Default) (Slaves: 12)
Channel 13: Clear channel (Default) (Slaves: 13)
Channel 14: Clear channel (Default) (Slaves: 14)
Channel 15: Clear channel (Default) (Slaves: 15)
Channel 16: D-channel (Default) (Slaves: 16)
Channel 17: Clear channel (Default) (Slaves: 17)
Channel 18: Clear channel (Default) (Slaves: 18)
Channel 19: Clear channel (Default) (Slaves: 19)
Channel 20: Clear channel (Default) (Slaves: 20)
Channel 21: Clear channel (Default) (Slaves: 21)
Channel 22: Clear channel (Default) (Slaves: 22)
Channel 23: Clear channel (Default) (Slaves: 23)
Channel 24: Clear channel (Default) (Slaves: 24)
Channel 25: Clear channel (Default) (Slaves: 25)
Channel 26: Clear channel (Default) (Slaves: 26)
Channel 27: Clear channel (Default) (Slaves: 27)
Channel 28: Clear channel (Default) (Slaves: 28)
Channel 29: Clear channel (Default) (Slaves: 29)
Channel 30: Clear channel (Default) (Slaves: 30)
Channel 31: Clear channel (Default) (Slaves: 31)

31 channels configured.


zttool

Alarm status fluctuates between ‘OK’ and ‘YELLOW’


cat /proc/zaptel/1 output

Span 1: WCT1/0 “Digium Wildcard TE110P T1/E1 Card 0” HDB3/CCS/CRC4 YELLOW

       1 WCT1/0/1 Clear
       2 WCT1/0/2 Clear
       3 WCT1/0/3 Clear
       4 WCT1/0/4 Clear
       5 WCT1/0/5 Clear
       6 WCT1/0/6 Clear
       7 WCT1/0/7 Clear
       8 WCT1/0/8 Clear
       9 WCT1/0/9 Clear
      10 WCT1/0/10 Clear
      11 WCT1/0/11 Clear
      12 WCT1/0/12 Clear
      13 WCT1/0/13 Clear
      14 WCT1/0/14 Clear
      15 WCT1/0/15 Clear
      16 WCT1/0/16 HDLCFCS
      17 WCT1/0/17 Clear
      18 WCT1/0/18 Clear
      19 WCT1/0/19 Clear
      20 WCT1/0/20 Clear
      21 WCT1/0/21 Clear
      22 WCT1/0/22 Clear
      23 WCT1/0/23 Clear
      24 WCT1/0/24 Clear
      25 WCT1/0/25 Clear
      26 WCT1/0/26 Clear
      27 WCT1/0/27 Clear
      28 WCT1/0/28 Clear
      29 WCT1/0/29 Clear
      30 WCT1/0/30 Clear
      31 WCT1/0/31 Clear

cat /proc/interrupts output

       CPU0

0: 5496330 XT-PIC timer
1: 11 XT-PIC keyboard
2: 0 XT-PIC cascade
4: 35 XT-PIC serial
8: 1 XT-PIC rtc
10: 9980 XT-PIC eth0
11: 201823 XT-PIC wcte11xp
12: 0 XT-PIC usb-ohci
14: 25764 XT-PIC ide0
NMI: 0
ERR: 0


zaptel.conf

loadzone = in
defaultzone=in
span=1,1,0,ccs,hdb3,crc4
bchan=1-15,17-31
dchan=16


zapata.conf

[channels]
language=en
switchtype=euroisdn
context=default
signalling=pri_cpe
group=1
channel => 1-15,17-31


Asterisk logs

[app_flash.so]May 20 18:56:18 NOTICE[2041]: chan_zap.c:6341 handle_init_event: Alarm cleared on channel 21
May 20 18:56:19 NOTICE[2040]: chan_zap.c:8202 pri_dchannel: PRI got event: HDLC Bad FCS (8) on Primary D-channel of span 1
May 20 18:56:19 NOTICE[2040]: chan_zap.c:8202 pri_dchannel: PRI got event: HDLC Bad FCS (8) on Primary D-channel of span 1
May 20 18:56:19 NOTICE[2040]: chan_zap.c:8202 pri_dchannel: PRI got event: HDLC Bad FCS (8) on Primary D-channel of span 1
May 20 18:56:19 NOTICE[2040]: chan_zap.c:8202 pri_dchannel: PRI got event: HDLC Bad FCS (8) on Primary D-channel of span 1
May 20 18:56:19 NOTICE[2040]: chan_zap.c:8202 pri_dchannel: PRI got event: HDLC Bad FCS (8) on Primary D-channel of span 1
May 20 18:56:19 NOTICE[2040]: chan_zap.c:8202 pri_dchannel: PRI got event: HDLC Bad FCS (8) on Primary D-channel of span 1
May 20 18:56:19 NOTICE[2040]: chan_zap.c:8202 pri_dchannel: PRI got event: HDLC Bad FCS (8) on Primary D-channel of span 1
May 20 18:56:19 NOTICE[2040]: chan_zap.c:8202 pri_dchannel: PRI got event: HDLC Bad FCS (8) on Primary D-channel of span 1
May 20 18:56:19 NOTICE[2040]: chan_zap.c:8202 pri_dchannel: PRI got event: HDLC Bad FCS (8) on Primary D-channel of span 1
May 20 18:56:19 NOTICE[2040]: chan_zap.c:8202 pri_dchannel: PRI got event: HDLC Bad FCS (8) on Primary D-channel of span 1
May 20 18:56:19 NOTICE[2040]: chan_zap.c:8202 pri_dchannel: PRI got event: HDLC Overrun (7) on Primary D-channel of span 1
May 20 18:56:19 NOTICE[2040]: chan_zap.c:8202 pri_dchannel: PRI got event: HDLC Bad FCS (8) on Primary D-channel of span 1
May 20 18:56:19 NOTICE[2040]: chan_zap.c:8202 pri_dchannel: PRI got event: Alarm (4) on Primary D-channel of span 1
May 20 18:56:19 WARNING[2040]: chan_zap.c:2290 pri_find_dchan: No D-channels available! Using Primary channel 16 as D-channel anyway!
May 20 18:56:19 NOTICE[2040]: chan_zap.c:8202 pri_dchannel: PRI got event: No more alarm (5) on Primary D-channel of span 1
Write to 52 failed: Unknown error 500
Short write: 0/5 (Unknown error 500)
May 20 18:56:19 NOTICE[2040]: chan_zap.c:8202 pri_dchannel: PRI got event: HDLC Bad FCS (8) on Primary D-channel of span 1
May 20 18:56:19 NOTICE[2041]: chan_zap.c:6341 handle_init_event: Alarm cleared on channel 22
May 20 18:56:19 NOTICE[2041]: chan_zap.c:6341 handle_init_event: Alarm cleared on channel 23
May 20 18:56:19 NOTICE[2041]: chan_zap.c:6341 handle_init_event: Alarm cleared on channel 24
May 20 18:56:19 NOTICE[2041]: chan_zap.c:6341 handle_init_event: Alarm cleared on channel 25
May 20 18:56:19 NOTICE[2041]: chan_zap.c:6341 handle_init_event: Alarm cleared on channel 26
May 20 18:56:19 NOTICE[2041]: chan_zap.c:6341 handle_init_event: Alarm cleared on channel 27
May 20 18:56:19 NOTICE[2041]: chan_zap.c:6341 handle_init_event: Alarm cleared on channel 28
May 20 18:56:19 NOTICE[2041]: chan_zap.c:6341 handle_init_event: Alarm cleared on channel 29
May 20 18:56:19 NOTICE[2041]: chan_zap.c:6341 handle_init_event: Alarm cleared on channel 30
May 20 18:56:19 NOTICE[2041]: chan_zap.c:6341 handle_init_event: Alarm cleared on channel 31
May 20 18:56:19 WARNING[2041]: chan_zap.c:6346 handle_init_event: Detected alarm on channel 1: Yellow Alarm
May 20 18:56:19 WARNING[2041]: chan_zap.c:6346 handle_init_event: Detected alarm on channel 2: Yellow Alarm
May 20 18:56:19 WARNING[2041]: chan_zap.c:6346 handle_init_event: Detected alarm on channel 3: Yellow Alarm
May 20 18:56:19 WARNING[2041]: chan_zap.c:6346 handle_init_event: Detected alarm on channel 4: Yellow Alarm
May 20 18:56:19 WARNING[2041]: chan_zap.c:6346 handle_init_event: Detected alarm on channel 5: Yellow Alarm
May 20 18:56:19 WARNING[2041]: chan_zap.c:6346 handle_init_event: Detected alarm on channel 6: Yellow Alarm
May 20 18:56:19 WARNING[2041]: chan_zap.c:6346 handle_init_event: Detected alarm on channel 7: Yellow Alarm
May 20 18:56:19 WARNING[2041]: chan_zap.c:6346 handle_init_event: Detected alarm on channel 8: Yellow Alarm
May 20 18:56:19 WARNING[2041]: chan_zap.c:6346 handle_init_event: Detected alarm on channel 9: Yellow Alarm
May 20 18:56:19 WARNING[2041]: chan_zap.c:6346 handle_init_event: Detected alarm on channel 10: Yellow Alarm
May 20 18:56:19 WARNING[2041]: chan_zap.c:6346 handle_init_event: Detected alarm on channel 11: Yellow Alarm
May 20 18:56:19 WARNING[2041]: chan_zap.c:6346 handle_init_event: Detected alarm on channel 12: Yellow Alarm
=> (Flash zap trunk application)
== Registered application ‘Flash’
[app_zapbarge.so]Executing last minute cleanups
== Destroying musiconhold processes
Yuck! Error in buffer handling…: Connection reset by peer
May 20 18:56:19 WARNING[2041]: chan_zap.c:6346 handle_init_event: Detected alarm on channel 13: Yellow Alarm
May 20 18:56:20 WARNING[2041]: chan_zap.c:6346 handle_init_event: Detected alarm on channel 14: Yellow Alarm
May 20 18:56:20 WARNING[2041]: chan_zap.c:6346 handle_init_event: Detected alarm on channel 15: Yellow Alarm
May 20 18:56:20 WARNING[2041]: chan_zap.c:6346 handle_init_event: Detected alarm on channel 17: Yellow Alarm
May 20 18:56:20 WARNING[2041]: chan_zap.c:6346 handle_init_event: Detected alarm on channel 18: Yellow Alarm
May 20 18:56:20 WARNING[2041]: chan_zap.c:6346 handle_init_event: Detected alarm on channel 19: Yellow Alarm
May 20 18:56:20 WARNING[2041]: chan_zap.c:6346 handle_init_event: Detected alarm on channel 20: Yellow Alarm
May 20 18:56:20 WARNING[2041]: chan_zap.c:6346 handle_init_event: Detected alarm on channel 21: Yellow Alarm
May 20 18:56:20 WARNING[2041]: chan_zap.c:6346 handle_init_event: Detected alarm on channel 22: Yellow Alarm
May 20 18:56:20 WARNING[2041]: chan_zap.c:6346 handle_init_event: Detected alarm on channel 23: Yellow Alarm
May 20 18:56:20 WARNING[2041]: chan_zap.c:6346 handle_init_event: Detected alarm on channel 24: Yellow Alarm
May 20 18:56:20 WARNING[2041]: chan_zap.c:6346 handle_init_event: Detected alarm on channel 25: Yellow Alarm
May 20 18:56:20 WARNING[2041]: chan_zap.c:6346 handle_init_event: Detected alarm on channel 26: Yellow Alarm
May 20 18:56:20 WARNING[2041]: chan_zap.c:6346 handle_init_event: Detected alarm on channel 27: Yellow Alarm
May 20 18:56:21 WARNING[2041]: chan_zap.c:6346 handle_init_event: Detected alarm on channel 28: Yellow Alarm
May 20 18:56:21 WARNING[2041]: chan_zap.c:6346 handle_init_event: Detected alarm on channel 29: Yellow Alarm


#2

The board was faulty


#3

I’m having the “exact” same problem, with that error

Write to 46 failed: Unknown error 500
Short write: 0/15 (Unknown error 500)

Changing the motherboard fixed the problem?


#4

We got digium to do a telnet to our machine. They concluded that the E1 card was not functioning properly and have sent us a replacement. Lets see if the new one works.


#5

I tried with 2 cards, one te110p and te205p, then only with a te205p and then only with a te110p. The problem still persists. So I’ll assume I have to change the motherboard.


#6

we tried a new te205p (3.3V) dual E1 card on a brand new machine. Things worked fine.


#7

Could you describe your older machine? Motherboard brand/model?

Thanks.


#8

Try to fix it with CentOS 4.3, with the kernel 2.6.9-34.0.1.EL
I had the same problems with yellow alarm and with the same kernel and centos 4.3

Span 1: WCT1/0 “Digium Wildcard TE110P T1/E1 Card 0” HDB3/CCS/CRC4

       1 WCT1/0/1 Clear
       2 WCT1/0/2 Clear
       3 WCT1/0/3 Clear
       4 WCT1/0/4 Clear
       5 WCT1/0/5 Clear
       6 WCT1/0/6 Clear
       7 WCT1/0/7 Clear
       8 WCT1/0/8 Clear
       9 WCT1/0/9 Clear
      10 WCT1/0/10 Clear
      11 WCT1/0/11 Clear
      12 WCT1/0/12 Clear
      13 WCT1/0/13 Clear
      14 WCT1/0/14 Clear
      15 WCT1/0/15 Clear
      16 WCT1/0/16 HDLCFCS
      17 WCT1/0/17 Clear
      18 WCT1/0/18 Clear
      19 WCT1/0/19 Clear
      20 WCT1/0/20 Clear
      21 WCT1/0/21 Clear
      22 WCT1/0/22 Clear
      23 WCT1/0/23 Clear
      24 WCT1/0/24 Clear
      25 WCT1/0/25 Clear
      26 WCT1/0/26 Clear
      27 WCT1/0/27 Clear
      28 WCT1/0/28 Clear
      29 WCT1/0/29 Clear
      30 WCT1/0/30 Clear
      31 WCT1/0/31 Clear

and after the start of the *

Span 1: WCT1/0 “Digium Wildcard TE110P T1/E1 Card 0” HDB3/CCS/CRC4

       1 WCT1/0/1 Clear (In use)
       2 WCT1/0/2 Clear (In use)
       3 WCT1/0/3 Clear (In use)
       4 WCT1/0/4 Clear (In use)
       5 WCT1/0/5 Clear (In use)
       6 WCT1/0/6 Clear (In use)
       7 WCT1/0/7 Clear (In use)
       8 WCT1/0/8 Clear (In use)
       9 WCT1/0/9 Clear (In use)
      10 WCT1/0/10 Clear (In use)
      11 WCT1/0/11 Clear (In use)
      12 WCT1/0/12 Clear (In use)
      13 WCT1/0/13 Clear (In use)
      14 WCT1/0/14 Clear (In use)
      15 WCT1/0/15 Clear (In use)
      16 WCT1/0/16 HDLCFCS (In use)
      17 WCT1/0/17 Clear (In use)
      18 WCT1/0/18 Clear (In use)
      19 WCT1/0/19 Clear (In use)
      20 WCT1/0/20 Clear (In use)
      21 WCT1/0/21 Clear (In use)
      22 WCT1/0/22 Clear (In use)
      23 WCT1/0/23 Clear (In use)
      24 WCT1/0/24 Clear (In use)
      25 WCT1/0/25 Clear (In use)
      26 WCT1/0/26 Clear (In use)
      27 WCT1/0/27 Clear (In use)
      28 WCT1/0/28 Clear (In use)
      29 WCT1/0/29 Clear (In use)
      30 WCT1/0/30 Clear (In use)
      31 WCT1/0/31 Clear (In use)

if you have problems by compiling zapata:
mail-archive.com/asterisk-de … 20214.html

thats not all :frowning:

the problem, that i have is to use channels with dial(ZAP…
i can dial but i get not response
the last one i can see in the * is
– Requested transfer capability: 0x00 - SPEECH
– Called 2/XXX

XXX is the number i´ve called

nothing happens until i hang up


#9

sorry, :blush:
my mistake,
i had the same problems of course with centos 3.5