ISDN BRI line problem


I am using a Digium B410p ISDN card, which I have been trying to get working.

My current setup is as follows: I have connected the trunk provided by my provider to an NT, and am using a straight cable to connect the NT to the card according to the specifications in the manual. Also, I have set the card jumpers to NT mode from default TE, installed all drivers etc.

However, all the LEDs on the card are still blinking red. From my understanding, the LEDs should be blinking green, if my hardware setting is working right.

Can it be a provider problem, or is it a problem at my end ( I am in India, and am using BSNL as the provider). I have checked that I am getting 96 V current at my end, so at least the provider is giving me the current.

I guess I need the green lights at least to progress from here.

Any ideas how I proceed or how I troubleshoot this?



I think you need to set your jumpers back to TE mode since you are connecting to an exchange not ISDNphones

Check the digium guide to installin the card at


Thanks for your reply Ian.

I was doing it wrongly, I have corrected my error and am using the right TE configuration now.

However, I am still not getting the green LED that I should. I suspect that it might be some cable problem. Here is the configuration of the straight cable I am using to connect the NT to my card:

3 - TX+
4 - RX+
5 - RX-
6 - TX-

This is from the manual itself. Also this is a straight cable, and not a cross one.

Is this right? What else can I do to troubleshoot this, my service provider is not being of much assistance here.


You get red flashing lights when nothing is plugged into the card.

These will stop flashing when you connect the lines up.

Does ‘mISDN scan’ see the card OK?

I have already inserted the line in the card, still it is flashing red.

I cannot run mISDN scan, asterisk tells me that it is an invalid command.

misdn show stacks returns the following:


  • Port 1 Type TE Prot. PMP L2Link DOWN L1Link:DOWN Blocked:0 Debug:0
  • Port 2 Type TE Prot. PMP L2Link DOWN L1Link:DOWN Blocked:0 Debug:0
  • Port 3 Type TE Prot. PMP L2Link DOWN L1Link:DOWN Blocked:0 Debug:0
  • Port 4 Type TE Prot. PMP L2Link DOWN L1Link:DOWN Blocked:0 Debug:0

So, apparently L1 and L2 links are down.

When I run misdn_checkl2l1, I get the following error:

Either the L2 and L1 on all of these ports where DOWN (see ‘show application misdn_check_l2l1’)

Is this a service provider problem, or am I doing something wrong at my end? I seem to be running out of troubleshooting ideas…


if you are using a straight cable then it does sound like a supplier issues as there is no L1 or L2 . What lights are on the supplier NT ?


On my NT, there are only two lights. One is power, which is on, and the other is U/S status, which is off.

On another note, I did not take the NT from my supplier. I just got an ISDN trunk from my supplier (BSNL India), and bought the NT from somewhere else. On my trunk, I have measured the voltage and it shows 96 V, which is correct.

Do I have to use a specific NT? Since I am getting the correct voltage, I am guessing that I am getting the current from the supplier. ( I don’t know what L1, L2 are, I called up my supplier and they were pretty clueless as well) In that case, does the fault lie with the NT?

Thanks for your help again!



you need to work out what this dhould show, the U is for U bus 2 wire the S is for S bus four wire.


If you are using Zaptel - did you do a ‘make b410p’?

Yeah, I did that of course.

Anyhow, I do not think I need to pay attention to my software setup, since my hardware setup is not working as of now.

According to my understanding, the green light on the card should come on irrespective of the software setup, if the card is able to receive signal from the exchange.

You ‘understand’ incorrectly. Remember - it is a solid [color=red]RED [/color]light when you card sees the exchange - not [color=green]GREEN[/color].

It only goes [color=green]GREEN [/color]when a channel is in use.

Oh, and it’s software that drives the card - ie you will get no lights until the drivers are loaded!

Oh, ok.

I am seeing a blinking red as of now, so no progress.

And yes, my drivers are loaded, I just checked. I have a feeling that the problem is with my NT, and am investigating that.

Thanks for your help!


You are correct, the blinking means no l1 or l2 which means you dont see any physical network (L1) and as such no data fill (L2) it may be that the NT is set to U, You need to get a engineer with a ISDN testbutt to check the line.

in the mean time What you could do is make up a ISDN2 loopback and check that the supplier can see it, It may be that you havent set the NT correctly.


The blinking red means that mISDN has seen your card and has loaded the drivers.

What OS are you using - as you NEED to set up a mISDN.conf file (usually in /etc) so that mISDN knows what to do with it.

Here’s mine (on Debian):

<?xml version="1.0"?> hfcmulti mISDN_dsp mISDN 1 2 3 4

I have ports 1 and 2 configured as TE - to connect them to trunks. Ports 3 and 4 I am using as NT (S0 bus) that I have ISDN modems plugged in to.

BTW a BN4S0 is a B410P card.

Oh - and don’t forget to leave the 100ohm termination OFF for TE mode (the mode you should be using).

So, I finally got it working.

Turned out that the fault was with the NT. We replaced the NT with another one, and then it just took a reloading of the drivers to get everything working.

Thanks for all the help!

I just realized that my dial out was working but dial in is not working!

This is pretty surprising.

When I dial in from my cell phone on my isdn number, I get a message “Your call cannot be completed due to congestion in the network”. The light on my card flickers from static red to green and back to static red again.

My extensions.conf file has the following entry for default calls:

exten => i,1,Playback(hello-file)
exten => i,n,WaitExten()
exten => i,n,Hangup()

The asterisk console actually tries to play hello-file (which exists), before abruptly exiting. ( I never hear any part of the file on my cell-phone, all I hear is an automated congested network warning from my service provider.)

Is this a driver issue, or some hardware issue?


exten => _X.,1,Playback(hello-file)
exten => _X.,n,WaitExten()
exten => _X.,n,Hangup()

Yes, it works with the change.

Thanks a lot!