IPKALL and asterisk (Call from '' to extension 'xx' rejected


#1

Hi,
If some one calls my ipkall number i would like to ring one of my extension on my asterisk account,

Currently I am running asterisk 1.6.x and I am able to make calls between my extensions I have setup an ipkall account and store all the requirement in the Ipkall record

Problem
I am experiencing this error message on the cli when I make a call from my cell phone to my Ipkall number

Aug 29 01:44:22] NOTICE[3755]: chan_sip.c:17675 handle_request_invite: Call from ‘’ to extension ‘205’ rejected because extension not found.
Scheduling destruction of SIP dialog ‘51380dd374e7e1e85a287bcd7a141964@66.54.140.46’ in 32000 ms (Method: INVITE)
localhost*CLI>

REQUIREMENT # 1
When some one calls to my ipkall number I would like my extension 205 to be ring and talk this is first time i am doin it but no luck any help is much appreciated

REQUIREMENT # 2
to be able to make calls to use using GVOICE or GTALK ( do have G talk account)

REQUIREMENT # 3
Use another IPKALL number use meetme for atleast 4 people

Here is my SIP.conf
[general]
port=5060
bindaddr=0.0.0.0
nat=yes
tos=0x18
srvlookup = yes
localnet=192.168.0.1/255.255.255.0
externip=1xx.20x.19x.xxx
;exterhost=
disallow=all
allow=all

[205]
type=peer
username=205
host=dynamic (I also tried voiper.ipkall.com and this caused my extension to unreachable)
context=home
secret=205
callerid= Farhan Line 2 Cordless
mailbox=205@default
nat = yes
disallow=all
allow = all
allow=g729
canreinvite = no
qualify = yes
dtmf = rfc2833
dtmfmode = auto
insecure = very

EXTENSION here is my extension.conf

general]

autofallthrough=yes

static=yes
writeprotect=no

[uri]
exten => _[a-z].,1,Macro(uridial,${EXTEN}@${SIPDOMAIN})
exten => _[A-Z].,1,Macro(uridial,${EXTEN}@${SIPDOMAIN})
exten => _X.,1,Macro(uridial,${EXTEN}@${SIPDOMAIN})

[home]

exten => 205,1,NoOp()
exten => 205,2,Dial(SIP/205,60)
exten => 205,3,Voicemail(205)
exten => 205,4,Hangup()

[macro-uridial]
exten => s,1,NoOp(Calling remote SIP peer ${ARG1})
exten => s,n,Dial(SIP/${ARG1},120,tr)
exten => s,n,Congestion()

ERROR MESSAGE
This is the error message
Aug 29 01:44:22] NOTICE[3755]: chan_sip.c:17675 handle_request_invite: Call from ‘’ to extension ‘205’ rejected because extension not found.
Scheduling destruction of SIP dialog ‘51380dd374e7e1e85a287bcd7a141964@66.54.140.46’ in 32000 ms (Method: INVITE)
localhost*CLI>
<— SIP read from UDP://66.54.140.46:5060 —>
ACK sip:205@mydomain.no-ip.org SIP/2.0
Via: SIP/2.0/UDP 66.54.140.46:5060;branch=z9hG4bK65a37e82;rport
From: “TORONTO ON” sip:4161234567@66.54.140.46;tag=as04037f08
To: sip:205@mydomain.no-ip.org;tag=as3dacb1e1
Contact: sip:4161234567@66.54.140.46
Call-ID: 51380dd374e7e1e85a287bcd7a141964@66.54.140.46
CSeq: 102 ACK
User-Agent: IPKall
Max-Forwards: 70
Content-Length: 0


#2

Set context=home in the general yection of Your sip.conf and the incoming calls from IPKALL will work with Your configs (after reloading sip.conf).
Your other requirements are a bit unspecific to be discussed in detail, but for the 2nd IPKALL-Account:
Depending on Your preferences define a extension at IPKALL (other than 205) to route the calls to and there You would use either Meetme or ConfBridge.
And for GTALK: Look araound here or use Your favourite search engine and You’ll find a lot of examples for GTALK-configs for asterisk to start with …


#3

Do ipkall register with you (unlikely)?

If not, host=dynamic will not work.

Although I thought the source code default for allowguest was no, it looks like you are being treated as though it were yes. I would explicitly set it to no.

Generally, you need the SIP starting at the INVITE, to see what is going wrong.

I assume this is a very old 1.6.x as I thought that message generally said which context it was trying.

Why do you have insecure=very, rather than invite? Is “very” still supported, rather than “port,invite”, in your version (it doesn’t seem to be supported in 1.6.1.0!)? Note service providers often give unsafe information in this respect, because they are too lazy to work out the least insecure setting. I think that is probably why it breaks when you specify a host.


#4

Thanks for the quick reply abw1oim
based on your suggestion my sip.conf should look like this (notice the last line in general
[general]
port=5060
bindaddr=0.0.0.0
nat=yes
tos=0x18
srvlookup = yes
localnet=192.168.0.1/255.255.255.0
externip=1xx.20x.19x.xxx
;exterhost=
disallow=all
allow=all
context=home

[205]
type=peer
username=205
host=dynamic (I also tried voiper.ipkall.com and this caused my extension to unreachable)
context=home
secret=205
callerid= Farhan Line 2 Cordless
mailbox=205@default
nat = yes
disallow=all
allow = all
allow=g729
canreinvite = no
qualify = yes
dtmf = rfc2833
dtmfmode = auto
insecure = very


#5

Hi david55
Do ipkall register with you (unlikely)?

[color=#8000FF]FH I did not try that becasue I endup storing the password on my sip.conf file
I can try that as well by using following command
register => ipkall useid [:secret[]]@ipkall.com[:port][/205] would it work [/color]

If not, host=dynamic will not work.

Although I thought the source code default for allowguest was no, it looks like you are being treated as though it were yes. I would explicitly set it to no.

Generally, you need the SIP starting at the INVITE, to see what is going wrong.

I assume this is a very old 1.6.x as I thought that message generally said which context it was trying.

Why do you have insecure=very, rather than invite? Is “very” still supported, rather than “port,invite”, in your version (it doesn’t seem to be supported in 1.6.1.0!)? Note service providers often give unsafe information in this respect, because they are too lazy to work out the least insecure setting. I think that is probably why it breaks when you specify a host.
[color=#BF00FF]can u please elaborate what and where to set?[/color]


#6

That register line is you registering with ipkall. For host=dynamic to work, ipkall must register with you.

You need to ask ipkall to give you a configuration for the version of Asterisk you are using. They may need to know the third part of the version number.

However, I would suggest:

[general]
allowguest=no

[ipkall]
type=peer
insecure=invite
host=
context=home

Also, please check for errors when loading your configuration, as insecure=very should have produced an error on 1.6.1 upwards, and probably on 1.6.0.