Interconnect Asterix with CUCM

Good morning,
We have created an Asterisk Server, Created some users, tested everything is working fine for now.
We tried interconnecting it with our CUCM, the IP phones from Cisco can dial and call phones on Asterisk, but phones on Aqterisk cannot reach the Cisco IP Phones,

whenever i try to make a call i recieve this Warning Message : app_dial.c:2787 dial_exec_full: Invalid timeout specified: ‘Cisco’. Setting timeout to infinite

Thanks in advance

You’d need to show the complete console output of an attempt. It sounds as if you’ve specified the wrong things to the Dial application.

1 Like

This is the only message i get on console ( without activating debug )

You need to increase the verbosity level.

However, as you’ve already been told, this sounds like a syntax error in your Dial application parameters.

this is the extension i am using currentyly : exten = _5XXX,1,Dial(SIP/${EXTEN:0},Cisco,20)

I used this one before but whenever i tried to make a call, on the device it shows error 503

;exten => _5XXX,1, Dial(SIP/${EXTEN:1})

What is the significance of the “Cisco”. It is certainly invalid, as it is in, as indicated by the error message, the timeout field. The 20 is also invalid as options, but a plausible timeout.

in sip.conf , this is Cisco :


The “,” should be an “@”.

i didn’t really get you, sorry

<— SIP read from UDP: —>
INVITE sip:5335 @;transport=UDP SIP/2.0
Via: SIP/2.0/UDP;branch=z9hG4bK-524287-1—3afc9f3cd5468b70;rport
Max-Forwards: 70
Contact: <sip:9000 @;transport=UDP>
To: sip:5335@

*********** This one is supposed to be @ CUCM adress but it shows Astersik adresse**

From: sip:9000@;transport=UDP;tag=0ea39b1d
Call-ID: l3damldBGRS5pgTL8CGhNA…
Content-Type: application/sdp
User-Agent: Zoiper rv2.10.3.0
Allow-Events: presence, kpml, talk
Content-Length: 189

That’s an incoming call to Asterisk from Zoiper. Asterisk would then execute dialplan and if configured send an INVITE out to CUCM.

should be

exten => _5XXX,1,Dial(SIP/${EXTEN:0}@Cisco,20)

Yes just figured that out, thanks.
Although there is an extension ( which David just suggesteed to modify ) But still not working

Hey David,
i just put the @ but just the message error changed ( ZoIper ) to Not found.

Now From the Asterisk ( 9XXX) i can call the Cisco ( 5XXX) but the opposite way just stopped ( and it was working before )

the New Warnings im getting :

[Nov 19 10:31:10] WARNING[30080][C-00000274]: chan_sip.c:6331 create_addr: Purely numeric hostname (5335), and not a peer–rejecting!

[Nov 19 10:31:10] WARNING[30080][C-00000274]: app_dial.c:2578 dial_exec_full: Unable to create channel of type ‘SIP’ (cause 20 - Subscriber absent)

That would be the result of doing DIal(SIP/5335,…) when there was not section 5335 in sip.conf.


This is My work Extension : [work]
exten => _9XXX,1,Dial(SIP/{EXTEN},20) exten => _9XXX,2,Hangup() exten => _5XXX,3, Dial(SIP/{EXTEN:0},1)
exten => _5XXX,1,Dial(SIP/{EXTEN:0}@Cisco,20) exten => _3XXX,1,Dial(SIP/{EXTEN:0}@Cisco,20)
exten => _4XXX,1,Dial(SIP/${EXTEN:0}@Cisco,20)
exten => _5XXX,2,Hangup()

Where the 9XXX are the phones on Asterisk and the 5XXX and 4XXX are the Phones on CUCM

Hi David So, When I added the Section [5335] in users :

host =
type = peer
username =
secret =
trunkname = Cisco
context = work
group = null
hasexten = no
hasiax = no
hassip = yes
registeriax = no
registersip = yes
trunkstyle = voip
insecure = port,invite
nat = yes
disallow = all
allow = ulaw,alaw,g729,g723,g726

Now all 9XXX can Call the phones on CUCM ( all CXXX) .

But only 5335 which is declared can call the 9XXX :confused:Preformatted text

Please use the </> button to correctly markup your code on the forum.

Did you reload the configuration? What does the verbose log entry show as the expanded Dial application call?

Extension _5XXX, priority 3, is unreachable, and it is confusing to mix and match extensions and have priorities out of order. Normally one would use “n” rather than explicitly numbering priorities.