Installing a digium TDM400P with 4 fxo

I am attempting to install a TDM400 with 4 FXO cards. I just installed Trixbox 1.1 from ISO and did an update via yum. I updated the spinlock.h file from nerdvittles. I then updated the zaptel drives from I compiled them using make clean, make install. I then ran genzaptelconf. But…when I run ztcfg -v I get:

zaptel version: svn-trunk-r1223
echo canceller: MR2

0 channels configured

None of my LED are on so I am assuming none of the channels are showing up. I turned everything off in the bios except the LAN and the IDE controllers.

I am very new to linux so any help would be appreciated.
By the way, the only way I have been able to edit files is through the text editor in Trixbox but it doesn’t let me get to all of the files. How do you edit the text files such as zaptel.conf? What command do I run to get to the text editor? Can I do that from another computer?


try ‘nano’ for a text editor. It works much like windows notepad. if you dont have it do yum install nano.

thanks…I now have nano up and running. I was able to edit the zaptel.conf it now is:

Autogenerated by /usr/local/sbin/genzaptelconf – do not hand edit

Zaptel Configuration File

This file is parsed by the Zaptel Configurator, ztcfg

It must be in the module loading order

Span 1: ZTDUMMY/1 “ZTDUMMY/1 1”

Global data

loadzone = us
defaultzone = us

When I run the command ztcfg -vvvv I now get:

Zaptel Version: SVN-trunk-r1223
Echo Canceller: MG2

Channel 01: FXS Kewlstart (Defualt (slaves: 01)

Channel 02: FXS Kewlstart (Defualt (slaves: 02)

Channel 02: FXS Kewlstart (Defualt (slaves: 02)

Channel 02: FXS Kewlstart (Defualt (slaves: 02)

4 Channels configured.

ZT_CHANCONFIG failed on channel 1: No such device or address (6)

At what point should I see the green LEDs turn on? This is a used board bought on EBAY and I am trying to find out if the board is bad or if my configuration is wrong. I don’t even have any POTS connected to the card I just need to know if the zaptel drivers are loading and if the card is working.


Have you searched the forums at There are known issues with trixbox and zaptel devices.

I can’t point you directly to a fix but I know I have seen them there.


Would I be better off to do a clean install of linux and asterisk rather than use tribox? Can I install the FreePBX gui with a standard asterisk install? I like the ability to log in via a browser from my other computer. It is much easier for a newbie such as my self.


You can do it from scratch. This link: … PBX-Centos

has a walkthrough of how to do it using Centos 4.3 with csreenshots and everything. :smiley:


I am working through a clean install from scratch not using Trixbox. But I am still concerned about this used TDM400 Card. Is there any way to test the card prior to having a fully functioning Asterisk install? Would zttool help me with this? What has to be installed for zttool to run? When will the LED light up? If they should be on from power up then I am wasting my time working with this card…but if they do not light up until all of the drivers are properly loaded and the zaptel.conf & zapata files are configured then I will keep working.

Thanks for the help