Incoming call to queue

Hi all

I’m try to setup queue to for incoming calls, but …

i’ve created a queue with 2 members
i’ve logged in this 2 members and test that they are ok
i’ve setted incoming rules to go to the queue …

when i call the phone number i’ve sent to the music on hold … nothing more … after time out connection is dropped (this even if 2 ext are online and free)

where’s the error?

See what i see in asterisk console:

== ISDN1#02: Incoming call ‘3357886693’ -> ‘309111783’
– Executing NoOp(“CAPI/ISDN1#02/309111783-434”, “Incoming-309111783:trunk_47 CallerID:”" <3357886693> - Calling:309111783") in new stack
– Executing AGI(“CAPI/ISDN1#02/309111783-434”, “incoming.php|answered=309111783&channel=47&rule=2&uniqueid=1214989688.3575”) in new stack
– Launched AGI Script /var/lib/asterisk/agi-bin/incoming.php
– AGI Script Executing Application: (macro) Options: (incoming-call-to-queue|||queue_79||||)
– Executing NoOp(“CAPI/ISDN1#02/309111783-434”, “”" <3357886693>") in new stack
– Executing Ringing(“CAPI/ISDN1#02/309111783-434”, “”) in new stack
– Executing Answer(“CAPI/ISDN1#02/309111783-434”, “”) in new stack
== ISDN1#02: Answering for 309111783
– Executing Wait(“CAPI/ISDN1#02/309111783-434”, “1”) in new stack
– Executing Set(“CAPI/ISDN1#02/309111783-434”, “ALERT_EXTERNAL=TRUE”) in new stack
– Executing Set(“CAPI/ISDN1#02/309111783-434”, “MOHCLASS=”) in new stack
– Executing GotoIf(“CAPI/ISDN1#02/309111783-434”, “1?enqueue”) in new stack
– Goto (macro-incoming-call-to-queue,s,9)
– Executing Macro(“CAPI/ISDN1#02/309111783-434”, “enqueue|queue_79|”) in new stack
– Executing Set(“CAPI/ISDN1#02/309111783-434”, “TIMEOUT(digit)=5”) in new stack
– Digit timeout set to 5
– Executing Set(“CAPI/ISDN1#02/309111783-434”, “TIMEOUT(response)=10”) in new stack
– Response timeout set to 10
– Executing GotoIf(“CAPI/ISDN1#02/309111783-434”, “1?defaulttimeout”) in new stack
– Goto (macro-enqueue,s,7)
– Executing NoOp(“CAPI/ISDN1#02/309111783-434”, “Timeout: 180 (default)”) in new stack
– Executing Set(“CAPI/ISDN1#02/309111783-434”, “timeout=180”) in new stack
– Executing Queue(“CAPI/ISDN1#02/309111783-434”, “queue_79|tw|||180”) in new stack
– Started music on hold, class ‘default’, on channel 'CAPI/ISDN1#02/309111783-434’
voip*CLI>

what does “show queues” say about the queue ?

Ian

mumble mumble

queue_79 has 0 calls (max unlimited) in ‘roundrobin’ strategy (0s holdtime), W:0, C:0, A:0, SL:0.0% within 0s
Members:
Agent/783 (Unavailable) has taken no calls yet
Agent/103 (Unavailable) has taken no calls yet
No Callers

but … i’ve extensions configured, not agent (i use voiceone.it as web interface)

and here’s my angent.conf

[general]
persistentagents = yes

[agents]
agent = 102,
agent = 103,
agent = 104,
agent = 105,
agent = 101,
agent = 200,
agent = 9999,
agent = 785,
agent = 783,
agent = 784,
agent = 7861,
agent = 7862,

where shoud i enable agent? on phone?

Problem seems that agents and extensions are not the same thing …

and in my ip phone linksys spa962 i just find extensions, not agent

where am i wrong?

Ste

Your agents needs to login. you don’t have any agent available…

here is part of my extension.conf
exten => 510,1,AgentCallbackLogin(||${CALLERIDNUM}@internal)
exten => 510,n,Hangup

so my agents call 510
the system ask them the agent number
they enter it then press #
then the system ask them to which phone/extension the system will send calls to
the agent enter its extension number and press #
then the system confirms that the agent is logged in…

in that case if you do
agent show
the system will show:


2*CLI> agent show
007 (Serge Pelletier) not logged in (musiconhold is ‘default’)
317 (Marc zzzz) available at ‘317@internal’ (musiconhold is ‘default’)
338 (Andre zzzz) not logged in (musiconhold is ‘default’)
|
*
|
9 agents configured [1 online , 8 offline]

… as you can see I have only 1 agent logged in…

Good suggestion, now a question: is there a way to have users automatically logged in when the relative extension is logged in?

Ste