Incoming call, Hangup() but line keeps busy

Hello,
I am a newbie in Asterisk …
Following instructions of the o’reilly book, I have configured Asterisk and made the recommended simple test (for the FXO) :
[incoming]
exten => s,1, Answer()
exten => s,n, Echo()
exten => s,n,Hangup()

It works fine, but when the caller from “outside” hangs up, the line keeps busy and Asterisk has an active call. I have to restart Asterisk to free the line…

I had a look in indications.conf and changed the default value from “us” to “fr” expecting it would solve the problem, but nothing changed.

I am using the latest version of Asterik, on a dedicated platform, installed via AsteriskNow.
Thank’s for your advice :wink:

Hi

This will be due to the Calling party disconnect signal. You need to talk to your telco to see what they have set, if anything and if they have nothing set ask for it to be enabled on your line.

Ian

Thank’s a lot, I am calling them tright away (expecting there are not yet on week-end) 8)

Well, well,

The solution is simplier, as most of the time.
Echo() is not the right command to use for testing purposes.
I changed Echo() with a Wait(2) and then things worked properly.
Asterisk hangs up et frees the line.

The example used in o’reilly manual (2nd edition) should be changed because you get very inconfortable sniffing around what you did wrong.

But now it is up and running well.
Thank’s for the answers and help :smile:
Olivier