Inbound set problem

i have setup a small auto attendant functions but it doesnt work whe i dial the number from outside.

exten => s, 1,Answer()
exten => s, 2,Background(greetings)
exten => 1, 1, Dial(SIP/john,19,r)

;what i am trying to do is to have a autoattendant menu. When number 1 is pressed it dials johns extensions number

Am I doing right?

This incoming is not VOIP but PSTN number. Should I put the local number or “s” is fine.


You have Exten => s, 1,Answer

Do you have the space berween s, and 1 in your extensions.conf ? Also what is coming up in the CLI. A way to test to see if it is even picking up is to play music on hold.

Exten => s,1,Answer
Exten => s,2,MusiconHold

If you call and you get the music then you have the pickup correct and it may be a problem with you sip settings. If not you have other issues.

thanks for that dovid

I think everything is o.k in the extensions. Its just when I call my landline from other phone it just rings and goes to my telecom providers voice meesage. So Asterisk does not take it.

I put my telecom company’s line into X100P 's telephone port (not the line port)

DO I have to make any special configuration in zapata.conf that matchs my telecoms providers conf?

Thanks for this in advance

well that’s not going to help much. it’s a line you’re bringing into the box, so it’s probably the line port you want.

as for config, read the docs in /usr/src/asterisk/doc or the example configs in /usr/src/asterisk/config or read the sticky at the top of this forum and visit the wiki at and search for “zaptel” and “zapata”