Inband doesn't detect dtmf of calleR and calleD same time

after solving a lot of problems for connecting Quintum Tenor A800 and Asterisk with SIP i think one problem is unsolvable or maybe an asterisk bug.

AsteriskNow = Asterisk 1.4.5 built by admin @ aomori on a i686 running Linux on 2007-06-22 23:12:57 UTC
Quintum Tenor A800
No NAT ( They are both in a switch )
Protocol SIP

everything work fine and there is just one big problem is there.

tenor a800 just supports Inband and H.245 for passing the dtmf to asterisk and therefore the Inband is my only choice and here problem begins

in the sip.conf when i put the dtmfmode=inband my internal office phone system works fine and employees could transfer calls etc BUT when customers connect from pstn (out of office) the IVR (which is the asterisk system that say press 1 for… press 2 for …) does not detect dtmf at all.

again i thought a trick and cleared the dtmfmode=inband from sip.conf and do this with SIPDtmfMode(inband) in my extensions.conf at the beginning of every incomming call and outgoing call.

now IVR works fine but when a call comes from the IVR which had inbanded with SIPDtmfMode(inband) the internal dtmf does not detected and transfer , call park or … does not work

and when an employee calls out which is inbanded with SIPDtmfMode(inband) ,the transfer and other features works fine but the called party dtmf could not detected.


…bla bla bla

…bla bla bla

:arrow_right: as i said when a caller calls in or calls out , asterisk can JUST detect the dtmf of CALLER and CANNOT detect the dtmf of Called party. i think this is a bug of asterisk ( i hope not )

Hi omidkosari,
I wish you could send me your configuration on A800. I’m not familiar at all with Quintum products but I must configure my A800 to send calls from Asterisk into the PSTN and from PSTN into Asterisk. I was able to register the A800 with Asterisk and when I issue “sip show peers” I see it registered and online. I’m at this stage now.

I tried a lot of settings after some googling but it’s not working for me and I think if you show me your complete A800 configuration I should be able to get some help.

Thank you in advance…

hi omid
i have same problem somehow , my problem is that sip phones can send DTMF through tenor but cisco phones cant , i set sip dtmfmode to info and it works well , but although i tested all options for dtmfmode in skinny.conf and in definition of sip trunk i could not solve this , have you solved problem ?

what is the version of your asterisk ?

In your channel config try relaxdtmf=yes