Ignore 183 early media

Hello all

I have a sip gateway for outgoing calls connect on my asterisk 11, who is sending me when a call is not answered a 183 progress with an early media recording "pls try again etc etc " and then after the 183 a 200 OK. This makes asterisk believe that the channel opened and thus producing an answered record on cdr reports. I’ve played around with prematuremedia and progressinband with no luck. Is there a way to ignore incoming 183 or the media?

Pls note that I dont care about hearing the early media, I’d rather drop the call

There’s no way configuration available to ignore that. The behavior based on what we’re getting is what most poeple would want.

Thanks for your reply jcolp,
What if I had another asterisk that generated the call connected to the first. The default behavior would be the first asterisk would forward the 183 progress and the media to the second. Is it possible to send an 180 instead of 183 from the first asterisk to the second? In fact this is what I am testing now. So far playing around with prematuremedia and progressinband (global settings) and/or “r” at trunk on the first asterisk doesnt seem to cancel the 183 rtp media

I wouldn’t expect media in early media state to generate an answer. Is that some new feature.

If you want to avoid early media, use the & notation with a local channel that never answers. Asterisk will only forward early media if there is one callee.