Ices, ices2 and icecast

Dear asterisk highnesses!

I am trying to stream audio from asterisk to icecast using the good hints on … k+cmd+ICES

However when I cp the .call files to /var/spool/asterisk/outgoing I get all these weired errors that I can’t make head or tail of (see below).

I also tried testing the Ices() command as such with

exten => [myExtension],1,Ices('/path/to/ices.xml')

but that didn’t seem to start the stream as well (which might be because it is completely wrong to do it like that…).

Ices invoked with a playlist works fine. I’m now on Ices0 as an mp3 stream is needed, but tried Ices2 before with the same result.

How should I best troubleshoot? Is what I’m doing utterly pointless?

Thanks and cheers,

Here’s the CLI output after copying to /var/spool/asterisk/outgoing:

[Jun 18 23:31:13] WARNING[2856]: pbx.c:4976 ast_pbx_outgoing_exten: Local/101@stream-b1cb,1 already has a call record??
       > Channel Local/101@stream-b1cb,1 was answered.
    -- Executing [100@stream:1] Answer("Local/101@stream-b1cb,1", "") in new stack
    -- Executing [100@stream:2] Wait("Local/101@stream-b1cb,1", "1") in new stack
    -- Executing [101@stream:2] Wait("Local/101@stream-b1cb,2", "1") in new stack
[Jun 18 23:31:14] WARNING[2856]: pbx.c:1797 pbx_extension_helper: No application 'MeetMe' for extension (stream, 100, 3)
  == Spawn extension (stream, 100, 3) exited non-zero on 'Local/101@stream-b1cb,1'
[Jun 18 23:31:14] NOTICE[2856]: pbx_spool.c:351 attempt_thread: Call completed to Local/101@stream
    -- Executing [101@stream:3] MusicOnHold("Local/101@stream-b1cb,2", "random") in new stack
[Jun 18 23:31:14] WARNING[2857]: res_musiconhold.c:947 local_ast_moh_start: No class: random
[Jun 18 23:31:14] WARNING[2857]: res_musiconhold.c:575 moh0_exec: Unable to start music on hold (class 'random') on channel Local/101@stream-b1cb,2
  == Spawn extension (stream, 101, 3) exited non-zero on 'Local/101@stream-b1cb,2'

Contrary to the above, it appears I have not yet found the right source client:
Ices0 - only does playlists, does not accept live input
Ices2 - accepts live input, reportedly works with asterisk (although I havn’t managed yet) but only does Ogg Vorbis
DarkIce - does mp3, accepts live input but needs Jack if there is no soundcard. Whether it works with asterisk is unclear
LiveIce - like DarkIce but no Jack support
The goal is to stream an asterisk channel to icecast as mp3. Is it at all possible? Would anyone have a hint for me?

Thanks and cheers,