IAX trunk with choppy music on hold

I am having an issue with an IAX trunk for PSTN termination and music on hold.

When a call is placed over an IAX trunk and the call is placed on hold the recording starts and then it cuts out over and over. I have seearched for a resolution to this and have learned that it is possibly due to silence suppression in the IAX protocol. Is there a way to resolve this? I am running Asterisk 1.2.15 and am thinking of upgrading to 1.4. I did see a mohsuggest and mohinterpret setting in 1.4 in iax.conf. Do these relate to this issue?


Hmm, since Asterisk does not handle silence suppression I doubt the option even exists for the IAX protocol. More likely its the end point that is suppressing silence or not, so you should look at the phone or software.

Just curious, are you using IDEFISK? I get the same choppy MOH when using this softphone.

I have heard that Silence Suppressions can play havoc with the MOH and also Comfort Noise Detection, if they are enabled try and have them turned off, however i am not sure if you want them turned off all the time or just during MOH or even if you can split it up that way.

I can see you having a lot of fun trying to resolve this problem, in the end we just stopped using Silence suppression and comfort Noise detection, for the little extra bandwidth you save it just was not worth it.

However if the End point must have it on, i don’t know of any other work around for it.



Nope i am not using IDEFISK. This is happening when I place an outgoing call over my IAX trunk to the PSTN and then place the call on hold. I have tried different encodings and the problem persist.

Is it possible to turn off comfort noise detection and noise suppression in an IAX trunk? I am using aastra 480i’s and I have silence suppression disabled on them. The choppy moh is quite annoying and when I go live with the system I can imagine the complaints from clients that are put on hold, which would filter back to me.

It may be a problem with the voip provider, if so do other voip providers not have this issue?

Link to tribox with same problem: