IAX trunk not reducing bandwidth even if "trunk=yes" is set

Hi everybody!

I’m failing since a couple of days in making my IAX trunk work properly, I mean reduce bandwidth consumption when making multiple calls.

In fact, I made a trunk between two Asterisk servers, and subscribers from each server can call anyone from the other server without any problem.

But the problem is that, even though I have set the “trunk=yes” parameter, IAX does not multiplex the multiple calls through the trunk (I captured then analysed the packets with Wireshark). However, I have res_timing_dahdi and res_timing_timerfd running. So, I really don’t understand where is problem.

**42VOIPSERVER*CLI> module show like timing**
**Module                         Description                              Use Count  Status      Support Level**
**res_timing_dahdi.so            DAHDI Timing Interface                   0          Running              core**
**res_timing_pthread.so          pthread Timing Interface                 0          Running          extended**
**res_timing_timerfd.so          Timerfd Timing Interface                 1          Running              core**
**3 modules loaded**

The iax.conf :


I’m using Asterisk 13.9.1 on Ubuntu 14.04.4 running on 2 VirtualBox VMs. Does the problem comes from the fact that I use virtual machines ?

If someone could help me, it would be great !

Thank you in advance!

If someone could help me, it would be great !

Thank you in advance!

Finally, I got the solution. The problem was that I didn’t uncomment the parameter “trunktimestamps=yes” in the iax.conf file on both servers.

Thank you anyway.