IAX softphone's sporadic performance - Keep Alive Issue?


#1

The problem is that my IAX softphone only receives calls sporatically.

I am using both Firefly and Diax (not at the same time!) to connect from inside my office network (behind NAT) to my Asterisk (1.0.9) box in my home (behind NAT.) The softphone registers as an extension no problem and originates calls perfectly. The problem is that incoming calls to Asterisk frequently do not ring my softphone although instructed to by the dial command. My gut tells me that this is a timing issue and that the office firewall is closing the connection just before the call comes in.

Can the frequency of the keep-alive packets be increased?

Below is the output of the CLI. gcleaves is the name of the IAX2 softphone extension. The output says “Called” but the phone does not ring. The other two extensions are on the same network as Asterisk and ring just fine.

Any ideas?

-- Accepting AUTHENTICATED call from 192.xxx.xx.xx, requested format = 4, actual format = 4 -- Executing Dial("IAX2/iax...@192.xxx.xxx.xxx:4569/2", "SIP/cordless&SIP/telefonica1&IAX2/gcleaves|20|tThH") in new stack -- Called cordless -- Called telefonica1 -- Called gcleaves -- SIP/telefonica1-52dd is ringing -- SIP/cordless-d992 is ringing -- Registered 'gcleaves' (AUTHENTICATED) at 6x.xxx.xxx.xx:37642 -- Nobody picked up in 20000 ms


#2

[quote=“gtcleaves”]The problem is that my IAX softphone only receives calls sporatically.

I am using both Firefly and Diax (not at the same time!) to connect from inside my office network (behind NAT) to my Asterisk (1.0.9) box in my home (behind NAT.) The softphone registers as an extension no problem and originates calls perfectly. The problem is that incoming calls to Asterisk frequently do not ring my softphone although instructed to by the dial command. My gut tells me that this is a timing issue and that the office firewall is closing the connection just before the call comes in.

Can the frequency of the keep-alive packets be increased?

Below is the output of the CLI. gcleaves is the name of the IAX2 softphone extension. The output says “Called” but the phone does not ring. The other two extensions are on the same network as Asterisk and ring just fine.

Any ideas?

-- Accepting AUTHENTICATED call from 192.xxx.xx.xx, requested format = 4, actual format = 4 -- Executing Dial("IAX2/iax...@192.xxx.xxx.xxx:4569/2", "SIP/cordless&SIP/telefonica1&IAX2/gcleaves|20|tThH") in new stack -- Called cordless -- Called telefonica1 -- Called gcleaves -- SIP/telefonica1-52dd is ringing -- SIP/cordless-d992 is ringing -- Registered 'gcleaves' (AUTHENTICATED) at 6x.xxx.xxx.xx:37642 -- Nobody picked up in 20000 ms [/quote]

I am having the same issue. Incoming calls will work for a few minutes right after i reboot my phone (Cisco 7960 or Sipura SPA-841) then they stop ringing the phone.

Have you figured this out yet?


#3

I don’t think these problems are related since you’re using SIP and I’m using IAX. And I assume your phone is on the same network as your server while my phone is behind a NAT firewall and on another network completely.

My problem has not been resolved, btw.

But if your phone is behind NAT then make sure your NAT settings in sip.conf are correct and you’reusing the ‘qualify’ option.


#4

[quote=“gtcleaves”]
But if your phone is behind NAT then make sure your NAT settings in sip.conf are correct and you’reusing the ‘qualify’ option.[/quote]

Yes phones are on a different network behind NAT, I added qualify=yes and the issue was resolved!

Thanks!