I don't receive fax with hylafax + iaxmodem

I have asterisk 1.6 on Centos 5.5 with hylafax 6.0.4 and iaxmodem.
The problem is that I can send fax but not receive. Then I think that is a problem of faxgetty.
This is the log of asterisk cli when I think to send fax myself.

    -- Accepting AUTHENTICATED call from
       > requested format = ulaw,
       > requested prefs = (),
       > actual format = ulaw,
       > host prefs = (ulaw),
       > priority = mine
    -- Executing [<my_number>@fax:1] Dial("IAX2/iaxmodem-701", "SIP/smsdiscount/<my_number>") in new stack
  == Using SIP RTP CoS mark 5
    -- Called smsdiscount/<my_number>
    -- SIP/smsdiscount-0000004c is making progress passing it to IAX2/iaxmodem-701
  == Using SIP RTP CoS mark 5
    -- Executing [<my_number>@incoming:1] NoOp("SIP/eutelia_fisso-0000004d", "estensione: <my_number>") in new stack
    -- Executing [<my_number>@incoming:2] Dial("SIP/eutelia_fisso-0000004d", "IAX2/iaxmodem/<my_number>") in new stack
    -- Called iaxmodem/<my_number>
    -- Call accepted by (format ulaw)
    -- Format for call is ulaw
    -- IAX2/iaxmodem-3656 is ringing
       > doing dnsmgr_lookup for 'voip.eutelia.it'
       > doing dnsmgr_lookup for 'voip.eutelia.it'
[Jun 29 00:53:33] WARNING[3344]: chan_iax2.c:3329 __attempt_transmit: Max retries exceeded to host on IAX2/iaxmodem-701 (type = 6, subclass = 11, ts=50009, seqno=14)
  == Spawn extension (fax, <my_number>, 1) exited non-zero on 'IAX2/iaxmodem-701'
    -- Hungup 'IAX2/iaxmodem-701'
    -- Hungup 'IAX2/iaxmodem-3656'
  == Spawn extension (incoming, <my_number>, 2) exited non-zero on 'SIP/eutelia_fisso-0000004d'


Jun 29 00:52:05 <host> FaxGetty[4255]: LOCKWAIT Jun 29 00:52:22 <host> FaxSend[4580]: MODEM WWW.SOFT-SWITCH.ORG spandsp/ Jun 29 00:52:22 <host> FaxSend[4580]: SEND FAX: JOB 29 DEST <my_number> COMMID 000000121 DEVICE '/dev/ttyIAX' FROM '<my_email>' USER admin Jun 29 00:53:07 <host> FaxSend[4580]: SEND FAILED: JOB 29 DEST <my_number> ERR [3] No answer from remote Jun 29 00:53:08 <host> FaxQueuer[4245]: NOTIFY: bin/notify.php "sendq/q29" "requeued" "" "00:58" Jun 29 00:53:08 <host> FaxQueuer[4245]: NOTIFY exit status: 0 (4590)

[code]# Run gettys in standard runlevels
1:2345:respawn:/sbin/mingetty tty1
2:2345:respawn:/sbin/mingetty tty2
3:2345:respawn:/sbin/mingetty tty3
4:2345:respawn:/sbin/mingetty tty4
5:2345:respawn:/sbin/mingetty tty5
6:2345:respawn:/sbin/mingetty tty6

Run xdm in runlevel 5

x:5:respawn:/etc/X11/prefdm -nodaemon

iax:2345:respawn:/usr/local/sbin/iaxmodem ttyIAX
mo:2345:respawn:/usr/sbin/faxgetty ttyIAX

minregexpire = 60
maxregexpire = 300

callerid=“Fax” <<my_number>>


device /dev/ttyIAX owner uucp:uucp mode 660 port 4570 refresh 300 server peername iaxmodem secret <my_password> cidname <my_society> cidnumber +39<my_number> codec ulaw

Thank you.

I’ve reinstalled hylafax. Now, whene I call a fax number I can listen fax tone after 3 rings.
This is the log:

== Using SIP RTP CoS mark 5 -- Executing [<my_number>@incoming:1] NoOp("SIP/eutelia_fisso-0000001a", "estensione: <my_number>") in new stack -- Executing [<my_number>@incoming:2] Dial("SIP/eutelia_fisso-0000001a", "IAX2/iaxmodem") in new stack -- Called iaxmodem -- Call accepted by (format ulaw) -- Format for call is ulaw -- IAX2/iaxmodem-3327 is ringing -- IAX2/iaxmodem-3327 answered SIP/eutelia_fisso-0000001a -- Hungup 'IAX2/iaxmodem-3327' == Spawn extension (incoming, <my_number>, 2) exited non-zero on 'SIP/eutelia_fisso-0000001a'
On the contrary, when I send a fax to myself I get this log repeatedly:
[Jun 30 01:33:45] WARNING[3074]: app_dial.c:1747 dial_exec_full: Unable to create channel of type ‘IAX2’ (cause 20 - Unknown)
== Everyone is busy/congested at this time (1:0/0/1)
– Executing [<my_number>@incoming:3] Hangup(“SIP/eutelia_fisso-00000018”, “”) in new stack
== Spawn extension (incoming, <my_number>, 3) exited non-zero on ‘SIP/eutelia_fisso-00000018’
== Using SIP RTP CoS mark 5
– Executing [<my_number>@incoming:1] NoOp(“SIP/eutelia_fisso-00000019”, “estensione: <my_number>”) in new stack
– Executing [<my_number>@incoming:2] Dial(“SIP/eutelia_fisso-00000019”, “IAX2/iaxmodem”) in new stack


Jun 30 01:32:40 <host> FaxGetty[2798]: LOCKWAIT Jun 30 01:32:49 <host> FaxSend[3033]: MODEM WWW.SOFT-SWITCH.ORG spandsp/ Jun 30 01:32:50 <host> FaxSend[3033]: SEND FAX: JOB 32 DEST <my_number> COMMID 000000171 DEVICE '/dev/ttyIAX' FROM 'user <email>' USER user Jun 30 01:33:35 <host> FaxSend[3033]: SEND FAILED: JOB 32 DEST <my_number> ERR [3] No answer from remote Jun 30 01:33:36 <host> FaxQueuer[2719]: NOTIFY: bin/notify.php "sendq/q32" "requeued" "" "01:38" Jun 30 01:33:37 <host> FaxQueuer[2719]: NOTIFY exit status: 0 (3064) Jun 30 01:33:48 <host> FaxGetty[2798]: MODEM WWW.SOFT-SWITCH.ORG spandsp/
Then i get the error “no answer from remote”.
What can be?

Now, I tried to send a fax to my server asterisk and I received this answer:
NOTICE[2970] chan_sip.c: No compatible codecs, not accepting this offer!
Seems everything is correct because iaxmodem answer, but after I get that error.

[general] context=incoming bindport=5060 binaddr= srvlookup=no disallow=all allow=ulaw allow=gsm language=it canreinvite=no qualify=yes dtfmode=rfc2833 externip=<my_ip> localnet= language=it


[incoming] exten => ${EXT_FAX},1,NoOp(estensione: ${EXTEN}) exten => ${EXT_FAX},n,Dial(IAX2/iaxmodem) exten => ${EXT_FAX},n,Hangup

I don’t expect you to be able to fax yourself like this (based on past trial and error).

Have you tried an analog fax to this box? I would remove any other variables that could be problematic, such as FoIP or anything that is not a true analog fax in this case…

Also what does “iax2 show peers” show?