I can't install chan_mobile

i’m new in asterisk. i would like to install chan_mobile with asterisk, but i tried many times,
and i can’t install…
i’m using asterisk version 1.8 and asterisk 10.0…
when i type make menuselect in add ons it show me chan_mobile, but has three XXX…
that means i have to install a dependence…but i already installed bluez-utils bluez-hcidump…
can anyone help me?
thanks to all.
ps: i’m using debian

menuconfig will also tell you which dependencies are missing, although it is easy to overlook this.

Did you run ./configure after installing the bluetooth libraries? Are you sure they are in a directory where configure looks for them? Are you sure that there is not a development package to install?

menuconfig said the dipendence was: Bluetooth (E)
but bluetooth works great…
i run ./configure before make menuconfig…

maybe i have to run [color=#FF0000]./configure --with-bluetooth[/color]
but when i run this i have this error:


checking for LOG_NEWS in syslog.h… yes
checking for LOG_SYSLOG in syslog.h… yes
checking for LOG_UUCP in syslog.h… yes
checking for mandatory modules: BLUETOOTH… fail

configure: ***
configure: *** The BLUETOOTH installation appears to be missing or broken.
configure: *** Either correct the installation, or run configure
configure: *** including --without-bluetooth.[/code]

is this the problem?

You will need to look at config.log and/or configure itself, to see where configure is looking and what it is looking for.

Also note that most with options are --with-XXXX=PATH. I have an older version, without chna_mobile so I can’t check this quickly.

so, how i must configure?
may i need another package that i didn’t installed?
thank you

I had to install libbluetooth-dev before ./configure recognized it.