I can't dial with any IAX softphone


#1

Hello everybody,

I installed Asterisk a few days ago, but i have a problem with IAX softphones.

I haven’t any problem using SIP soft. I can call IAX softphones with the most of SIP softphones or IP HardPhones.

But, if can’t call any SIP or IAX soft WITH an IAX softphone. I try with Idefisk, Firefly, IaxComm and Asterisk says the same mistake :

“chan_iax2.c:5761 socket_read: Rejected connect attempt from 172.20.42.42, request ‘200@default’ does not exist”

In this exemple, i try to call extension 200, which is a SIP softphone (or IAX).

thank you.
aurelien


#2

The context that you have assigned to the IAX softphones in your /etc/asterisk/iax.conf are not the ones needed to be able to dial 200. As you may see from the error log it can not find 200@default, which means the IAX phone is trying to dial 200 inside of the context ‘default’. What context does 200 exist in in your /etc/asterisk/extensions.conf? That is the one you need to assign for this particular dialing to work.


#3

thank you i found the solution.

I had wroten : “context=test” in the general section (in iax.conf). Actually, it doesn’t seem to work. I have to put “context=test” in each section of my IAX phones.
This problem doesn’t appear in sip.conf file.

Is it a bug ?


#4

No, different protocols with different configuration/usage concepts. Have a look here starting at page 60. Note that there is no ‘conext’ setting in the general section but only in the entity sections.


#5

yes, there is no context setting but if you go to page 64 :

options for entities

“context: When used within a client definition, this keyword overrides
the default incoming context set in the general section for the user
only.”

Then, there is a default context in the general section :smile: Or maybe we can’t change it.


#6

Bingo. Having said this, I did some testing with v1.2beta, and I am able to manipulate the codec usage globally in the general section of /etc/asterisk/iax.conf.