I can't configure for use 2 softphones


#1

Hi,

I’m trying to configure Asterisk for use 2 softphones in different computers of a same company. But when I make a call, for example, from 3000 to 3001, in 3000 apparently makes the call, but 3001 don’t receive it. Also, when I start to make the call, the console say “disconnected to Asterisk server”.
Here I put the code that I wrote in the files extensions.conf and sip.conf, I didn’t edited no other file, because I think that is not needed for use softphones (if I’m mistaken, please tell me):

[code] ; SIP.CONF
;=========================================
;
[general]
;
port=5060
;disallow=all
allow=g726
allow=ulaw
allow=alaw

[3000]
type=friend
host=192.168.1.60
language=es
context=default
secret=jose
username=3000
callerid=3000
dtmfmode=rfc2833
qualify=yes
;
[3001]
type=friend
host=192.168.1.60
language=es
context=default
secret=jose
username=3001
callerid=3001
dtmfmode=rfc2833
qualify=yes
; [/code]

; EXTENSIONS.CONF ;========================================= ; [default] ; exten => 3000,1,Dial(SIP/3000,26) exten => 3000,n,Hangup ; exten => 3001,1,Dial(SIP/3001,26) exten => 3001,n,Hangup ;

When I make reload in the console appears this Error:

ERROR[436]: chan_fx.c:5223 setup_fx: Unable to reconfigure channel '1,1,0’
ERROR[436]: chan_fx.c:5223 setup_fx: Unable to reconfigure channel ‘2,2,0’

Please help!! :cry:


#2

Are You sure concerning the ERROR-Message? (as I don’t know what chan_fx.c should be :question: )
Two other problems visible from Your configurations in a quick-.view manner:

First: If the clients are softphones which should probably register with asterisk, there should be host=dynamic within the definitions in sip.conf.
If they - very unlikely - should not register, then the host-entry doesn’t match Your description of two different computers where the softphones reside as You’re using the same IP-adress/port in the configs.
Second: (Not necessary at the first moment but should also be done consequently) There’s no localnet and externip/exetrnhost definition in the general-section of sip.conf, this will lead to problems when trying to make/receive outside calls.

And: when Asterisk disconnects fromk cli there are usually some more errors/misconfigurations ahead on Asterisk start. Probably You should have a look at /var/log/asterisk/messages which should at leasst contain all relevant ERROR/WARNING-Messages during Asterisk start which could be analyzed for any crash reason.


#3

Hi abw1oim,

Thanks for your reply. I just set host=dynamic like you told me. Also localnet=192.168.1.60/255.255.255.0 and
externip=192.168.1.60. And now when I make Reload appears 1 unique Error:

ERROR[6196]: chan_fx.c:5223 setup_fx: Unable to reconfigure channel ‘1,1,0’

If you don’t know this, is maybe because I instaled Asteriskwin32 in a Windows server 2003… I’m not in Linux :blush: Also I can see this messages:

NOTICE[6196]: cdr.c:1217 do_reload: CDR simple logging enabled.
NOTICE[6196]: identifications.c:505 ast_unregister_indication_country: Removed default indication country 'us’
WARNING[6196]: chan_fx.c:5527 setup_fx: Ignoring signalling
WARNING[6196]: chan_fx.c:5527 setup_fx: Ignoring rxwink
WARNING[6196]: chan_fx.c:5527 setup_fx: Ignoring tonezone
NOTICE[6196]: chan_iax2.c:8936 set_config: Ignoring bindport on reload
NOTICE[6196]: chan_iax2.c:8976 set_config: Ignoring bindport on reload

I can’t see the Warning messages in the route you toldme (perhaps in Windows is other route). But now, when I start Asterisk, in the begining I can see this messages:

NOTICE[6196]: chan_tapi.c:890 load_module: Channel format set to ULAW’
ERROR[6196]: chan_tapi.c:965 load_module: Unable to register device 'MODEM1’
ERROR[6196]: chan_tapi.c:965 load_module: Unable to register device ‘MODEM2’

Also I tried again the sofphones, and now they can’t make a call, this say “failed to establish call”. And the console say me this:

[NOTICE[6196]: app_dial.c:1076 dial_exec_full: Unable to create channel of type ‘SIP’ (cause 3 - No route to destination)

:open_mouth:


#4

ok, externip can’t be correct, as this means Your external (internet) ip-address, it can’t be part of the localnet!
chan_fx (which seems to be a channel for operating anlogue/isdn-lines) should be excluded from load (in modules conf), as this module seems to load incorrectly as You probably doen’t install any telephony interface card in Your box.
chan_tapi seems to be the same, cause here it’s complaining about missing modems. If You don’t need the module, just disable it in modules.conf.
The SIP-failure could be related to my first sentence, You should however - before dialing - look for the output of sip show peers and sip show registry to make sure, Your softphones are registered with asterisk and willing to perform basically.


#5

Ok, thank you very much for the help, I have it almost…
Now in the console not appears Errors, only when I start Asterisk, the last line say:

NOTICE[6292]: chan_sip.c:11889 sip_poke_noanswer: Peer ‘3001’ is now UNREACHABLE! Last qualify: 0

How I must configure the softhphone?? I don’t understand the last sentence you said:

Here is how I configured the SIP Acount of my Softphones (X-Lite 4 both):

3001

Account name: Prueba
Protocol: SIP
Allow this account for: call & IM Presence
User ID: 3001
Domain: 192.168.1.60
Password: jose
Display name: Prueba
Authorization name: 3001
Send outbound via: Proxy
Address: 192.168.1.60

3000 (The computer where I have instaled Asterisk)

Account name: jm
Protocol: SIP
Allow this account for: call & IM Presence
User ID: 3000
Domain: 192.168.1.60
Password: jose
Display name: Jose
Authorization name: 3000
Send outbound via: Proxy
Address: 192.168.1.60

Is not this configuration the needed for register the softphones with Asterisk?? Then, what I must do for register :question: :question:


#6

No this is all correct: The problem You’re sseing:

only tells You, that 3001 ist (in the momeent the message occures) not reachable for asterisk. This could mean high network latency or a disconnect from the client itself. If the softphones as well as the server reside in the same local network You won’t need to have the qualify-option (responsible for this message) enabled. You may disable it for sip-peers 3000 and 3001 in sip.conf by adding a

to the sections of each peer.
What I meant with my last remark from older post was to check the functionality of the client_connection to asterisk by issuing the mentioned commands at the asterisk-CLI.


#7

I just set qualify=no in both peers, and I have the same result when I make calls…

NOTICE[6196]: app_dial.c:1076 dial_exec_full: Unable to create channel of type ‘SIP’ (cause 3 - No route to destination)

I will continue investigating and if I find what is causing the prblem, I will tell. Anyway, thank you very much for your support :wink:


#8

qualify=no won’t fix routing problems, it will just remove the unreachable warning. You need to fix your routing problem outside Asterisk. I’d start by using traceroute, although note that that, and ping, can fail even when normal traffice works.


#9

Ok, I’m now making calls without problem!! :mrgreen:
The cause was, in X-Lite I wasn’t checked the option “Register with domain and receive calls”. I had not realized this until now… :blush:
so, problem solved. Thanks!!