Howto changer the default callerid(asterisk)

Hi ,
I cant get callerid on zap channels which is fine but on the display it shows “asterisk”, is there anyway to change this to another word like “xyz”?


Set(CALLERID(name) will set the name and (num) will set the number.


You can also change this in zapata.conf

how can I change this in zapata.conf? I tried callerid=something
but it didnt work

Hi Ian,

We have callerid working but when the caller ID is blocked by the person calling us it says from Asterisk. Is there a way to change it to something else instead of Asterisk only when no caller ID is no sent?

So do a gotoif (if the callerid(name) = asterisk then set it to foo)

I’m assuming you mean calls coming in over SIP and connecting to Zap channels. If that is the case, then the option you are looking for is the “callerid” option in the [general] section of sip.conf.

This option will set the default callerid for incoming SIP calls.