How to remove NOTICE from incoming OPTIONS


In a SIP trunking setup (ie Asterisk exchanging call with various IPBX), remote IPBX sends OPTION messages, probably to keep NAT connections alive.

Asterisk is 13.14.1.

Some of these OPTION messages are currently logged with lines such as:
[Mar 30 14:47:03] NOTICE[1047] res_pjsip/pjsip_distributor.c: Request ‘OPTIONS’ from ‘“foo” sip:foo@’ failed for ‘’ (callid: 75ef950e799462990d24171a4ae70568) - No matching endpoint found

Please, note that the above example:

  • the real endpoint (attached to ‘’) is named ‘bar’ (and not ‘foo’ as expressed in From username part)
  • I’ve got no control over the device sending this OPTION (it can be any IPBX from any vendor and most IPBX sys admins are unable to tune the way OPTION messages are sent)

How can I remove these log lines (without changing logging config) ?

Best regards

Edit the source code, remove the obvious line, and recompile.

I must say I’m far more inclined to tweak PJSIP endpoint matching rules to force matching between OPTION messages and endpoints ;-))

I’ve seen authenticate_qualify option but:

  • it seems to apply to outbound qualifies
  • and even if you could apply to inbound qualifies, I don’t know if devices would reply to such challenges.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.