How to config res_snmp.conf?

HI, I configure asterisk + snmp like this:
Step1: Recompile asterisk with enable res_snmp module
Step2: Enable subagent = yes and enabled = yes in res_snmp.conf
Step3: config snmpd.conf:
rocommunity test
master agentx
agentXSocket /var/agentx/master
agentXperms 0660 0775 root root

step4: Copy and paste the text from the following two wiki pages into two seperate files in the /usr/share/snmp/mibs direcotry.
*** [|DIGIUM-MIB.txt]
*** [|ASTERISK-MIB.txt]

STEP5: Restart snmpd and asterisk
The content of log is:
Oct 31 17:11:11 dhcppc2 snmpd[1207]: Received TERM or STOP signal… shutting down…
Oct 31 17:11:11 dhcppc2 kernel: netlink: 12 bytes leftover after parsing attributes.
Oct 31 17:11:11 dhcppc2 snmpd[1471]: Turning on AgentX master support.
Oct 31 17:11:11 dhcppc2 snmpd[1473]: NET-SNMP version 5.5
When I run # snmpwalk -On -c test -v 2c localhost asterisk , I see:
No log handling enabled - turning on stderr logging
asterisk: Unknown Object Identifier (Sub-id not found: (top) -> asterisk)

and when I run #snmpwalk -c public -v 2c localhost ASTERISK-MIB::asterisk, I see:
ASTERISK-MIB::asterisk = No more variables left in this MIB View (It is past the end of the MIB tree)

What is the problem?