How do I disable the Privacy DB?

We’re getting a wierd issue when a call comes in to a specific number. Normally the call comes in and is forwarded to an IAX or SIP trunk. But with this number the call comes in and we get the following:

Accepting call from ‘8325551212’ to ‘7135551212’ on channel 0/6, span 1
– Executing Wait(“Zap/6-1”, “2”) in new stack
– Executing Dial(“Zap/6-1”, “SIP/7135551212@209.163.188.200|60|&SIP/7135551212@209.163.188.200|60|”) in new stack
– Privacy DB is ‘7135551212’, clid is ‘8325551212’
– Playing ‘priv-recordintro’ (language ‘en’)

A recording plays asking the caller to enter their telephone number.

We do not have the privacy manager loaded as far as we cal tell. There is nothing in extensions.conf or other config files referencing the privacy manager. Even though it was not specifically loaded in modules.conf we unloaded the privacy module with a noload => statement and in the asterisk cli we manually unloaded it.

But, when the number is called we still get that error.

Anyone know how to turn off this thing?

Config Info:

Asterisk 1.2.16
Sangoma A101 T1
Sangoma A200 4/FXS

Okay, on further review of the system via a “database show” I see something like this:

/privacy/7135551212/2127967930 : allow
/privacy/7135551212/2813233556 : allow
/privacy/7135551212/2814425364 : allow
/privacy/7135551212/2814425379 : allow
/privacy/7135551212/2814425836 : allow
/privacy/7135551212/2814916027 : allow
/privacy/7135551212/7137232974 : deny
/privacy/7135551212/7186663108 : allow
/privacy/7135551212/8322792977 : allow

Does this mean the privacy manager is enabled? If so how? There is absolutely no reference to the privacy manager in any of the config files. This system is only supposed to be a gateway to the PBX systems, so how would I turn this off?

Okay, it looks like what is happening is called “screening” which you can enable with the “p” option on a DIAL command.

But, I’ve looked through every entry in extensions.conf and I can’t find a “p” option on any of the dial statements. And this only happens on one SIP trunk, the other SIP trunks are processed normally.

Does anyone know how to disable this feature? Help!

It looks like I simply messed up the dial command.

The PBX we’re sending to requires that we send ${EXTEN}@IP for it to be able to determine the DID. I must have done a copy/paste and ended up with something like this:

exten => DID,2,Dial(SIP/${EXTEN}@IPADDRESS|60|&SIP/${EXTEN}@IPADDRESS|60|)

This of course is calling the same number twice. It should have been this:

exten => DID,2,Dial(SIP/${EXTEN}@IPADDRESS|60|/${EXTEN}@IPADDRESS)

Not sure why this was kicking off the “screening mode” but changing the dial string appears to have resolved the problem.