How do I access my external MYSQL database from Asterisk dialplan?

Hi guys, I am trying to access my external database from an Asterisk dialplan but I get the error “No application MySQL for extension mycontextname”.

So I run “module show like mysql” and it shows 0 module. I read somewhere that I need to install but I couldn’t find luck getting this ones I found to work,

When I extract it to modules folder /usr/lib/asterisk/modules directory and run asterisk -rx “module reload”

It still shows 0 module when I run “module show like mysql”. What am I doing wrong?

Also I am using Asterisk 13.10.0

You can try other methods like func_odbc or the System() but anyway in case you want to use mysql() application this thread could help

I guess the error is an absent of a mysql module such as, but I can’t find a compatible one, the previous ones I used still gives me 0 module when I run “module show like mysql”

I haven’t used that module, but you can use the make menuselect in order to diagnose any dependencies needed for that module , also try running the contrib/scripts/install_prereq install " Note the path for the script is relative to your system"