HELP with SIP trunk

Hello. I’m a complete newbie on VoIP and Asterisk. So for a start :

I bought an JS200-FX appliance from X100p http://www.x100p.com/products/js200fx.php with Asterisk v1.4.
After some time spent in Trunk configuration i was able to configure the sip trunk for my sip provider, with some configurations i’ve find on the internet for portuguese provider SAPO.

When i execute the command sip show peers i get this info:

Name/username Host Dyn Nat ACL Port Status
trunk_1/+351302052423 213.13.89.67 N 5070 OK (27 ms)
1 sip peers [Monitored: 1 online, 0 offline Unmonitored: 0 online, 0 offline]

When i execute the command sip show registry i get this:

Host Username Refresh State Reg.Time
voip.sapo.pt:5060 +35130205242 120 Request Sent
proxy.voip.sapo.pt:5070 +35130205242 3585 Registered Thu, 29 Mar 2012 04:28:34

So, for what i can see i was able to register in the proxy but not in the host. I’ve tried all kind of changes, but i don’t know how can i track what is wrong.

When i use a SIP client on windows (X-lite 4) i can register and make and receive calls. But not with the asterisk.

Wich log shall i check to see what’s appening?

Jose.

Hello m8, could you please post your trunk configuration here(se vc quiser pode me perguntar em português tb).

Hi Jo-ka

Could you please tell me how you manage to suscribe a voip sapo account ?

Regards

Can you post your sip registration string blanking out any username/password info. Also I take it this is a NATed connection? Have you setup your external IP address and local network settings? I see this is an appliance with a GUI. There will probably be someone in the GUI to set these.