[HELP] Inbound Caller ID Issues - Asterisk


I am currently installing Asterisk onto a new CentOS 4 machine and am running into some caller ID issues (in Australia).
I am hoping to use this new machine to replace our old Redhat/Asterisk 1.0.7 box in a call centre environment.
We use a Quintum DX to route the incoming calls from an ISDN E1 (10 channel) to our Asterisk machine. We dont have any zap cards in the Asterisk machine.
The caller ID seems to get passed through OK to the old asterisk machine, but on the new Asterisk machine - it just comes through blank most of the time. When trying to fiddle with the dialplan, the closest i can get to a caller ID is the IP address of the Quintum, sometimes i just get “asterisk”.
The config i am using on the new Asterisk machine is identical to the older Asterisk 1.0.7 config - except for a couple of minor syntax changes etc…

So as far as i can tell - it seems that the newer version of asterisk could be the cause of the issue.
I noticed in the changelog for the asterisk 1.2 series - it mentioned a complete Caller ID overhaul - maybe i am missing something.

If anyone can offer any advice on this one - it would be greatly appreciated - im stuck for ideas.


Ryan P.

help us help you by posting the incoming context from extensions.conf and perhaps a SIP debug for an incoming call.

I cant get a sip debug yet.

Here is the sip.conf entry for the quintum

[3000] type=friend username=3000 secret=**** host=dynamic context=mainmenu mailbox=3000 nat=yes reinvite=no canreinvite=no callerid=<3000>

incoming over this goes to mainmenu context like so

[mainmenu] exten => 61312341234,1,Goto(bnet,s,1)

then here


exten => s,1,Ringing
exten => s,2,Wait,2
exten => s,3,GotoIfTime(06:00-22:00|mon-fri||?bnet-menu,s,1)
exten => s,4,GotoIfTime(08:00-20:00|sat||?bnet-menu,s,1)
exten => s,5,GotoIfTime(10:00-18:00|sun||?bnet-menu,s,1)[/code]

then here


exten => s,1,Set(CALLERID(all)=BNET-${CALLERID(num)})
and then call is queued etc…[/code]

the above line is ‘supposed’ to append “BNET-” to the front of the callerid number. I get just “BNET-” most of the time, or “BNET- 3000” or just "asterisk"
On our older asterisk machine (which CID works on) all dialplan & conf is the same- except CID was set like this:

which worked fine.

Maybe my syntax is wrong (i hope its that easy), but i have tried every possible combination & variable i can think of.

Hope this sheds more light on this, if you need any more info let me know