[Help] Asterisk Newbie Question


I have a Asterisk server and Few Softphones with Private IP behind NAT and a Tenor VoIP Gaeway on public IP.

I can make calls between Private IP Softphones using Asterisk. Also using the Softphone I can direcly make calls to Tenor Gateway (without using Asterisk).

Next I am trying to make calls to Tenor Gateway via the Asterisk Server. When I dial a number 1 I can see asterisk box sending packets to Tenor gateway but I don't see any return packet from the Tenor.

In my NAT router I have the Asterisk server setup as DMZ.

I am not sure If i need to turn on “nat=yes” for Softphone. I set it “no” since both Asterisk and softphones are inside NAT and share same Public IP.

I was just wondering if this type of setup works!!

My basic configuration:

qualify=yes ;
host=dynamic ;
canreinvite=no ;
context=sip ;

qualify=yes ;
host=dynamic ;
canreinvite=no ;
context=sip ;
nat=no ;

exten => 1,1,Dial(SIP/5324030@137.xx.xx.23)
exten => 1,n,Hangup()

exten => 1007,1,Dial(SIP/1007)
exten => 1007,n,Hangup()

exten => 1001,1,Dial(SIP/1001)
exten => 1001,n,Hangup()


You need to allow ports 5060 and 10000 through 20000 inbound from the gateway through your firewall to the asterisk server.

I might also add that if your gateway has a public IP, you should restrict SIP traffic to it from your asterisk server only, otherwise one day someone will figure it out and start placing calls through your gateway.

Right, I have setup DMZ in the NAT router so all the new resquests get forwarded to the Asterisk server.

Today I tried with:
a. softphone inside NAT (myself)
b. softphone somewhere else in the Internet but again behind NAT (friend in internet)

I was able to get Rings but neither of us could listen to each other. Is this NAT traversal problem?


I have a similar problem (but works in iax2 extensions without sound problem). But even from within the same network behind the same firewall, my softphones (no problem with the hardphone connected to sipura3102 except # and * dialling) could not sent the dtmf signal to the autoattedant at the callee’s end (says no digits are received). The latter condition applies to both protocols: sip and iax2 .

I am trying to solve the problem for the last three weeks. Someone suggested at asteriskguru’s site that for xlite to work I have to port forward from 8000-20000, I did so. But still not working.

I also copied portion of the sip.conf to sip_nat.conf. Still not working. I consulted almost every book and posted everysite, still I could not find any solution to the problem like that of yours.

Is it a problem with asterisk itself? Or is it unresolvable? I humbly request the asterisk experts to help this newbie. Thanks in advanced.

firstly, stop with the multiple posts. you have a problem and you’ve posted your own thread. don’t hijack others, especially when it’s not related to the thread you’re hijacking.

secondly, stop with the multiple posts !!