[HELP] Asterisk and Net2phone


I have an * machine, which I configured using the instructions on voip-info.org for placing calls through Net2phone.

So far I can get the * to register with Net2phone, place a call, but it when the other party’s phone rings I dont hear anything, and then on the CLI, I get the message that its been answered and almost immediately it disconnects, still with no sound. I know the other party’s phone is ringing cause I tried calling my number and it rang, but when I picked, it was dead silence and then a disconnect tone.

I used an unlocked firmware downgarde on my Packet8 DTA to enable me use it as a generic SIP client to *, and thats where I place my calls from. I have tried all kind of settings on the * box, on the DTA and all kinds of changes to my sip.conf, as I initially thought it might be a CODEC problem, but nothing seems to work. My * machine is behind NAT but other Net2phone hardware on the same network can place calls easily without any problems, so I dont know if it could be a NAT problem.

I’ve tried searching this forum and the voip-info.org wiki with no luck, about how to solve this.
Has anyone ever tried something of this nature and gotten it to work? if anyone might have some input as regards what might be the problem or where I may need to look, I would appreciate it greatly. Thanks.


I’m having the same problem as you do. When I call a regular phone, the other phone rings, but I don’t hear the ring tone. And when the other phone answers the call, it gets disconnected.

I tried calling a Net2Phone VoiceLine. I could hear the ring tone, but the call was disconencted the same way as the other one.

I checked the N2P configuration guide for the PAP2, and found that it will only work with G723. Please check below:

Audio Configuration
􀂊 Preferred Codec = G723
􀂊 Use Pref Codec Only = no
􀂊 G729a Enable = no
􀂊 G723 Enable = yes
􀂊 G726-16 Enable = no
􀂊 G726-24 Enable = no
􀂊 G726-32 Enable = no
􀂊 G726-40 Enable = no
􀂊 FAX Codec Symmetric = yes
􀂊 DTMF Tx Method = AVT
􀂊 Hook Flash Tx Method = None
􀂊 Release Unused Codec = yes

Also, as far as I’m concerned, the Asterisk does not support G723, as it is a licenced codec.

I’m also stuck on this issue… If anyone could help, I’d really appreciate.


Andre Abrahao