Hardware Problem?

I built a new Asterisk server using an existing server, a Dell 2950 and new Digium TE220B and an AEX800. I’ve used Asterisk 1.8.0 Beta 5, DAHDI 2.4.0, LibPRI 1.4.11.4. Linux version information: Linux version 2.6.18-128.7.1.el5. It crashes shortly after being booted, here’s some of what I believe is pertinent from dmesg:

ACPI: PCI Interrupt 0000:0e:08.0[A] -> GSI 16 (level, low) -> IRQ 169
wctdm24xxp 0000:0e:08.0: Host failed to service card interrupt within 128 ms which is a hardunderun.
wctdm24xxp 0000:0e:08.0: Port 1: Installed – AUTO FXS/DPO
wctdm24xxp 0000:0e:08.0: Port 2: Installed – AUTO FXS/DPO
wctdm24xxp 0000:0e:08.0: Port 3: Not installed
wctdm24xxp 0000:0e:08.0: Port 4: Installed – AUTO FXS/DPO
wctdm24xxp 0000:0e:08.0: Port 5: Installed – AUTO FXS/DPO
wctdm24xxp 0000:0e:08.0: Port 6: Installed – AUTO FXS/DPO
wctdm24xxp 0000:0e:08.0: Port 7: Installed – AUTO FXS/DPO
wctdm24xxp 0000:0e:08.0: Port 8: Installed – AUTO FXS/DPO
dahdi_vpmadt032_loader: module license ‘Digium Commercial’ taints kernel.
wctdm24xxp 0000:0e:08.0: Booting VPMADT032
wctdm24xxp 0000:0e:08.0: VPM present and operational (Firmware version 125)
wctdm24xxp 0000:0e:08.0: Configuration of ports failed (3)!
wctdm24xxp 0000:0e:08.0: Found a Wildcard TDM: Wildcard AEX800 (0 BRI spans, 7 analog channels)
wctdm24xxp 0000:0e:08.0: Power alarm on module 1, resetting!
wctdm24xxp 0000:0e:08.0: Power alarm on module 1, resetting!
dahdi_transcode: Loaded.

I think the AEX800 has a problem but I wanted to tap into the expertise here and get other thoughts or things to check.

Thanks,

Steve