Gtalk problem out of LAN


#1

Hi all, I configured Gtalk and asterisk and seems work pretty well. But I noticed that when i am out of office and I am tryng to call from gmail to gtalk user ( associated to asterisk ) voice flow does not work.
A deeper investigation lead me into STUN problem. Gtalk use STUN mecchanism to find where gtalk user ( associated to asterisk server ) is.
Does anyone had same issue? How did you solve it?
Thanks.


#2

Hi nobody had this issue?


#3

So far I think I fixed this issue on my system with firewall port settings … but it’s been an intermittant problem and therefore difficult to solve or know for sure if it’s solved, yet.

follow my thread here:
pbxinaflash.com/forum/showthread.php?t=11098

I’m investigating this suggestion now, from the nerdvittles.com site:
“Solving One-Way Audio Problems. If you experience one-way audio on some of your phone calls, you may need to adjust the settings in /etc/asterisk/sip_custom.conf. Just uncomment the first two lines by removing the semicolons. Then replace 173.15.238.123 with your public IP address, and replace 192.168.0.0 with the subnet address of your private network. There are similar settings in gtalk.conf that can be activated although we’ve never had to use them. After making these changes, save the file(s) and restart Asterisk with the command: amportal restart.”


#4

“/etc/asterisk/sip_custom.conf” ought to be replaced by “/etc/asterisk/sip.conf”, or any of the files directly or indirectly included by it.