Got SIP response 302 "Moved Temporarily"


I have an asterisk v1.8 install on my fc16 server connected to a cable modem with Optimum’s voice service. I inherited this system from the previous admin. I also upgraded from a really old version to this v1.8 quite some time ago, and thought it was working correctly since that upgrade.

It seems now incoming calls to all but one extension work properly. We have two physical polycom phones that are connected. When dialing the 7000 extension, it rings on that phone. The 7003 extension reports the following:

  == Using SIP RTP CoS mark 5
    -- Called SIP/7003
    -- Got SIP response 302 "Moved Temporarily" back from
    -- Now forwarding DAHDI/1-1 to 'Local/1201g79343@trusted' (thanks to SIP/7003-00000000)
[Jul 18 21:05:15] NOTICE[30367]: app_dial.c:892 do_forward: Not accepting call completion offers from call-forward recipient Local/1201g79343@trusted-9604;1
[Jul 18 21:05:15] NOTICE[30367]: chan_local.c:899 local_call: No such extension/context 1201g79343@trusted while calling Local channel
[Jul 18 21:05:15] NOTICE[30367]: app_dial.c:980 do_forward: Forwarding failed to dial 'Local/1201g79343@trusted'
  == Everyone is busy/congested at this time (1:0/0/1)

I have no idea what’s wrong, or how to troubleshoot it and hoped someone could help. I have the following relevant lines in extensions.conf:

exten           =>  7000,1,Macro(stdexten,SIP/7000,7000)
exten           =>  7003,1,Macro(stdexten,SIP/7003,7003)
exten           => s,1,Dial(${ARG1},20,tr)
exten           => s,2,Goto(s-${DIALSTATUS},1)

exten           => s-NOANSWER,1,Voicemail(${ARG2}@local,u)      ; No answer.
exten           => s-NOANSWER,2,Hangup
exten           => s-BUSY,1,Voicemail(${ARG2}@local,b)          ; Phone busy.
exten           => s-BUSY,2,Hangup
exten           => _s-.,1,Playback(invalid)             ; Channel unavailable.
exten           => _s-.,2,Goto(incoming,_1NXXNXXXXXX,4)

I’m really not sure what other information to provide, but really hoping someone can help. I’ve also uploaded my extensions.conf and sip.conf to pastebin:



Please let me know what other information I can provide to resolve this.


Check polycom phone config. Seems that call forwarding is enabled on phone.

–Satish Barot


Not from the asterisk side, your polycom phone is answering :

Check on the Polycom is forwarding is ON

That was it – thanks so much, guys.

I spent hours working on this. Perhaps my cat walked across the buttons or it happened during cleaning. I was wondering why it was reporting a strange forwarding number!

Thanks again,