Go back to an asterisk version

Hello people,

Currently in my Ubuntu I have installed version 20-0-0 of asterisk, I would like to know if I can go back to version 18 without losing all the configurations already made?

I would backup the /etc/asterisk directory were all the config files live. This overall should work; however it’s no guarantee everything will work. It will ultimately depend on what you have configured and what changed between 18 and 20. Most of my configs for 18 transferred over to 20 with no problem.

Might I inquire as to why you wish to go back? Are you running in to a specific problem with 20 that might just need some additional attention someone could help you with?

I saw that there are some module replacement changes: Asterisk 20.0.0 Now Available ⋆ Asterisk and they stopped working, so I wanted to go back to old version that worked and see if that’s what is causing the error.

There is no automatic upgrade of configuration files, so I can’t see that there is anything that will need downdating, unless you changed it yourself.

I’ll explain my case, to see if anyone can help me:

in my database I have these tables created for asterisk:
image

I configured my ura so that when I call 1130, it plays the audio and options for each sector:

But when I connect it gives the following error:
erro ura

file extension.conf:

are in the same context, but returning this error, if you need more prints, let me know and I’ll send them here.

1130 according to your database is in context phones, not phones-local

true, now that you commented that I saw it.

Sorry for the question, how do I change the context of that table within mysql?

You just have to update the extension field within the MySQL table. How you do that is up to you; you can do it in command line or with a SQL editor of some sort. I don’t deal with SQL very often.

hello friend,

I decided to change the extensions to the phones context, I tested a call and it worked.

Thank you for your help.

sorted out.