g729 was working now getting No Compatible Codecs

Ok, So here is the issue and i’ll try not to take up to much of everyones time.

I installed g729 about a week ago on our Asterisk server all was working fine, the twinkle sip phone on our ubuntu computers where operating like they should and connecting to the asterisk server. well thats until the following happened.

Yesturday 4:25pm I in vicidial added user 8002

I went to login using the clients ubuntu computer and got 488: not acceptable here
on Asterisk I got

NOTICE[3911]: chan_sip.c:5826 process_sdp: No compatible codecs, not accepting this offer!

At 4:30 a chain reaction started happening where user by uyser who had been placing calls all day started to not be able to getting the 488 error.

I removed g729 from the sip.conf file and replaced it with alaw

disallow=all allow=alaw ;allow=ulaw ;allow=gsm

restart the asterisk and restarted twinkle.

Same error happened again.

Note: We use to allow=all I even tried this and well no luck.

I then put tried another sip client bria and it worked (not sure why)

I am wondering the following:

  1. It was working why now has it stopped
  2. Do I need to update the OS to ubuntu 12 (currently ubuntu 8)
  3. Did Asterisk corrupt the codecs when it crashed
  4. How do I fix this.

I will say I am a total noob at asterisk I have worked with vicidial to a point doing lists etc. and my background is php and databases so I am a little out of my confort level.

However I want to learn and any advise to fix this issue I will try.

Ok an update on this situation.

I found out that g729 was also set in vicidial codec - DONT DO THAT
I switch internal to alaw - g711a
from server to Outside g729

so it goes

alaw internal
g729 external

and so far its all good, after I rebooted to server