FXS to FXO connections dropped


#1

I have a analogue PSTN line connected to A@H.
When incoming calls is received an analogue extension(FXS on TDM400P) is rung.
The call is answered and intermittantly the call is dropped after varying time frames (anything from 5 secs up to 1 hour after answering).

I have changed all hardware and also tried Asterisk 1.3, 1.5 and 1.7.
The problem stays with me and I don’t know where to look for the cause anymore.

I changed motherboard( now Intel Augsburg) with Hyperthreading (on or off still dropping calls), 512 MB RAM, 3 GHZ cpu, bought new DTM400 and FXS,FXO modules.
Previously I ran Red Hat 9.0 with Asterisk, but now A@H 2.5 on CentOS.

I had echocanceling on and off, busy detect on and off and answeron polarity swops on and off, but still I find that the box drops calls.

I ran ztmonitor and the levels vary between 98.9 and 100.0 so that also seems fine.

I swopped my system PSU for a 450 watt where it used to be a 300 watt.

Still the problem remains:
On incoming or outgoing calls one talks and then suddenly the call is terminated and I get internal dail tone. Again this is on an analogue PSTN on a FSO connected to an FXS port and analogue telephone.

Any ideas on this problem?