func_odbc + MS SQL server does not return the whole value

Hey All,

Add thing. I am just trying to return the whole date time stamp from a SMALLDATETIME field in a MS SQL server.

Problem is I only get the first 15 back from the field. Like so…

Connected to Asterisk 1.8.6.0 currently running on [REDACTED]-dev (pid = 2240)
Verbosity is at least 3
[REDACTED]-dev*CLI> odbc read ODBC_[REDACTED]-LOOKUP 104809 exec
DateCreated           2011-12-19 13:2
Returned 1 row.  Query executed on handle 0 [asterisk-mssql-connector]

Notice how it only returns “2011-12-19 13:2” and not the rest of the time… I have run the query on the SQL server and then from isql and it works everytime leaving the only abstraction point Asterisk.

Any thoughts?

Thanks!!

Shameless bumb :wink: Although I can add that I just tried this on an Asterisk 10 box with the same result. I’ll keep plugging away at it.

Thanks!!

I have setup SQL Server with FreeTDS

When i run the isql -v asterisk-connector

unnable to connect

when i run isql-v asterisk-connector username password

this working.

when i run cli command odbc read isexistscall exec

returning execution failed. I’m running this on Asterisk 1.8.0

Hello!

I am having the same problem of hariram302. Did you have some update in this issue?

Thanks!