Forward calls are melted

Hi all,

i have quite a weird problem with asterisk version 20.3.0 : the forwarded call is not the correct one.
i’m using SNOM 735

just to explain :

  • from my phone i call my customer and told him “can i speak to John Doe ?”
  • He calls John, says do you want to talk to Cehes
  • During this time, using my mobile phone, i call the customer again, this is ringing…
  • Then the customer forward the call to John.

the weird thing is that this is not the first call that is forwarded, but the second one, the one that was calling…

Can you understand such a thing ?
I tried it many time, same result, the call that is forwarded is the second one the one that is ringing not the one that was replied

I can not see interesting thing on sngrep…

Any idea on what is wrong ?

Thanks !

Why do you think this related to Asterisk?

You talk about calls made from your Snom 735, and from your mobile phone.

Do both of these go through your Asterisk server? Or are we talking about an
Asterisk server you have access to at the customer’s premises?

Please give a more detailed description of the call flow for the two calls,
explaining which servers and telephones are involved in each call.

Antony.

thanks for such a quick reply !

Indeed not sure this is related to asterisk.

Sorry i should have been more precise, here are better informations :

I am calling from the outside using my fixed phone and mobile phone. This test could be done from everywhere else (because they have the problem with differents callers)

My customer is using asterisk with some SNOM phones, Jane is the attendant, John the user i want to call

Using my fixed phone i call (using public number) Jane and tell her “can i speak to john”. She does a forward to John and speak some seconds with him.
During that i use my mobile phone (to simulate a call from someone else) to call Jane again and she let it ring.
Then she does a forward of the call and then my first call that was waiting is not forwarded, this is the second one the one that was ringing. In real life it means that she forward someone else :slight_smile:

Please tell me if this is clear
Cehes

This is indeed much clearer - thank you.

Now we need to know details like:

a) exactly how is the transfer of the call by Jane being done?

b) what is shown in the verbose log file for the dialplan actions for the
entire duration (first call coming in, to second call mistakenly transferred)?

Antony.

In fact, snom phones can be tricky when it comes to transferring a call while another call is ringing in. You easily transfer the wrong call if you don’t do it the right way. But that’s not really an asterisk issue.

So, I suggest either Jane practices a bit with her phone to train this situation or her admin disables call-waiting on her phone and instead creates a queue for her at the asterisk server. This way one call after the other will arrive at her phone and there is no danger that wrong call gets transfed.

Thanks for that !
Yes you’re right i should have read the dialplan log, i totally forgot, but friday was a hard day :slight_smile:
I’ll do an rasterisk -vvvvv and see what happens.

i’ll also ask Jane what she excatly does, because her reply was “as you show me when you installed the phone”, but i know she can easily mistaken…

I will keep you updated

TheNextDay, i guess you could be right, the problem is that this customer is quite far from me.
But Jane already did think not the way we shown her during the install, maybe that’s the case here even if she said that she does as i shown her.
I’ll then do test again, but ask her, step by step, key by key what is she doing.

Thanks to both of you

I have also some users who have problems handling transfers when there are a lot of calls at the same time. That’s where I usually turn off call waiting as said and use a queue on asterisk side. That way they always have only one call at the same time, reducing risk to get confused.

Thanks for that !
I’ll take a look at asterisk queue, i never used it…

I fact i simplified the explanation but Jane is one of the attendant, there are 3 attendants in fact that are called by a group, but this does not change the problem as all are having the problem (but this is Jane who explained how to do at the 2 others attendant :slight_smile: ), not sure queues can be applied here then ?

By the way i’ll have to know what they exactly do, i guess i’ll connect a phone at my company to their asterisk and then i’ll be able to do tests my myself.

Hi all,

as promised i did some tests, here is what i can tell you :
First of all lets say Jane is the attendant, John the sales manager she wants to forward to and there is customer1 and customer2 who calls
Jane has a BLF with Joe on it

Customer1 is calling, Jane takes the call
She press the BLF for Joe, she speaks to John
Customer2 is calling
Jane press “transfer” and here customer2 is forwarded to John (it should have been Customer1)

We found a solution that is working, but that isn’t convenient :
Customer1 is calling, Jane takes the call
She press “transfer”, then type the John’s number (like 301), and press “attended” and speak to John.
Customer2 is calling
Jane press “transfer” and John is then speaking to customer1, Jane is then able to take customer2’s call

How can i have the best of each world ?
Do i misunderstand something ?

thanks for your help

Please provide the SIP protocol logs (enable the full log, and issue “pjsip set logger on” (or for the obsolete driver, “sip set debug on”).

However, this sounds to be an issue with the phones, not with Asterisk.

Note that Asterisk has no concept of BLF.

Hi David,

i agree with you this seems related to SNOM more than asterisk.
Then i opened a case with snom and they gave me a parameter to change.
I will test it and post it here if it is ok

Well the parameter given by SNOM corrected the issue !
You just have to change that :

quick_transfer - Snom Service Hub - Snom Service Hub

hope this could help somebody else, and thanks to everybody who helps !

1 Like

To which value did you set the setting?
The default is new_call which should have behaved as you need it from beginning on.

I would have assume attended transfer…

1 Like

Shame on me : i give a clue without the complete solution… sorry !
David is right, the right param is attended.
You can also find this setting into gui : advanced/behaviour

Have a nice day !