Force to send RTP keepalive

Hi,

my asterisk is doing some diaplan extension code, and everytime when I make a call with Dial command, the gateway will automatically closes the connection as it did not receive any audio in 7 seconds. So I’m doing the the Playback(welcome) command when the other side (another asterisk) answers. What is the best way to send RTP keepalives so the gateway would think there is audio being sent and will not close the session ? Thanks.

Use following parameter:

rtpkeepalive = Number : Number of seconds, when a RTP Keepalive packet will be sent if no other RTP traffic on that connection. Default 0 (no RTP Keepalive).

For more information take a look at voip-info.org/wiki/view/Aste … g+sip.conf