[Fixed] Configuring for Callcentric.com?

Hey guys,

I have tried following CallCentric’s support document located here: callcentric.com/support/device/12 to configure Asterisk for their service. When I do however, I can never connect with any soft phone software (I am on OS X, trying to use LoudHush) without Asterisk spitting back an error like so:

So obviously I am still not quite understanding how to get soft phone’s registered with the Asterisk system. Thing is, I am not sure if CallCentric’s support doc is correct.

So, what I am asking all you kind folks is two things.

1: Does the CallCentric document properly explain and configure the sip.conf and extensions.conf?

2: How do I get soft phones (like LoudHush) to work with this configuration?

Thanks in advance guys, I am totally pumped to see this stuff working!

Are you sure that you did not modified your IAX configuration file instead of sip.conf?

Aug 20 09:46:25 NOTICE[1032]: chan_iax2.c:5126 register_verify: No registration for peer ‘17772364601’ (from

Also, in sip.conf you need to have, anywere in your callcentric user definition:


because you are behind a router.

Hi mirceahuh,

Thanks for the reply.

I am sure I was only modifying sip.conf and after adding nat=yes I get the same result. One thing I should mention is when I type “sip show peers” in the Asterisk console, this is the output I get.

LKG7E7916*CLI> sip show peers Name/username Host Dyn Nat ACL Port Status gizmo/17476318035 N 5060 Unmonitored ht286/ht286 (Unspecified) D 0 Unmonitored sipurafxs1/sipurafxs1 (Unspecified) D 0 Unmonitored sipurafxo1/sipurafxo1 (Unspecified) D 0 Unmonitored ms1/ms1 (Unspecified) D N 0 Unmonitored 123/123 (Unspecified) D 0 Unmonitored xlite1/xlite1 (Unspecified) D 0 Unmonitored callcentric/17772364601 N 5060 Unmonitored 8 sip peers [8 online , 0 offline]

Heading back and reading the documentation from Callcentric leads me to believe that something with their configuration is either wrong, or incomplete.

Any ideas? Thanks again!

Hi travisbell,

Can you pase here the result of sip show registry?


No problem,

LKG7E7916*CLI> sip show registry Host Username Refresh State callcentric.com:5060 17772364601 45 Registered proxy01.sipphone.com:5060 17476318035 1785 Registered

Ok. I was blind before.

It is clear that your softphone is not registered. You said that you use LoudHush to connect to the asterisk box. Are you sure that you configured it well, and also that you have an iax2 user for it in iax.conf?


Actually no, what would the configuration look like for iax.conf?

The reason I thought it was a sip.conf/extensions.conf error is because of the fact 123/123 is not connected(?) to a host in the peers list.

Thanks man, you are being an enormous help.

An update,

I have made some progress I think…

I can now login with Loud Hush (sweet) but when I try and make a phone call, I am getting the following error:

So, after lots and lots of digging I can’t really find other with this issue. Anyone got some insight?

Ok. You see, 123 user from callcentric.com website is an example of configuration. But you don’t need this user in sip.conf, since you connect with an iax softphone.

You have in iax.conf a user. If you follow the example on their website, your iax user must be in to-callcentric context.

On the other hand, in extensions.conf you will have:

exten => s,1,Dial(IAX2/xxx) ; where xxx is your iax user definition in iax.conf

And by the way, on callcentric.com website they have, in extensions.conf:

exten => _XX,1,Dial(SIP/${EXTEN}@callcentric)

This will have to be:

exten => _XX.,1,Dial(SIP/${EXTEN}@callcentric)

You must have that dot after _XX, which means that will match anything so you can dial any number you want (of any length). Please verify also that you haven’t put here @callcentric.com

And, if you want, you can use a prefix to dial through this provider:

exten => _9X.,1,Dial(SIP/${EXTEN:1}@callcentric)

In this example I used 9, but you can use any number you want. It is usefull because you will have to make a difference bettwen calls to your users and calling out from your asterisk box.

Aha! Got it man, thanks a bunch for your help!

I’m glad I could help.