Feom-sip-external context modification

Hi , all
i just wanted to answer any sip incomming call to a queue number 50

i need to customize the dialplan below such that any incomming calls enter the context "from-sip-external- to go to the queue number 50

;give external sip users congestion and hangup
; Yes. This is really meant to be _. - I know asterisk whines about it, but
; I do know what I’m doing. This is correct.
exten => _.,1,NoOp(Received incoming SIP connection from unknown peer to ${EXTEN})
exten => _.,n,Set(DID=${IF($["${EXTEN:1:2}"=""]?s:${EXTEN})})
exten => _.,n,Goto(s,1)
exten => s,1,GotoIf($["${ALLOW_SIP_ANON}"=“yes”]?from-trunk,${DID},1)
exten => s,n,Set(TIMEOUT(absolute)=15)
exten => s,n,Answer
exten => s,n,Wait(2)
exten => s,n,Playback(ss-noservice)
exten => s,n,Playtones(congestion)
exten => s,n,Congestion(5)
exten => h,1,NoOp(Hangup)
exten => i,1,NoOp(Invalid)
exten => t,1,NoOp(Timeout)

wish to help , thankx

That should be trivial for anyone who understands the risks of using “_.”.

can you help plz ?

If you are using FreePBX, you need to go to the general setting and set allow anonymous calls to yes.

Then under incoming route, set any did that go to the queue 50.

Next question please visit community.freepbx.org/