Fax For Asterisk: problem loading module


Im trying to install FFA.

The asterisk is version runs on centos 5.4 32bit. (its a trixbox install)
I have installed the lisence, but when i try to load res_fax.so i get the following error:
Unable to load module res_fax.so
Command 'module load res_fax.so ’ failed.
[Apr 7 11:33:18] WARNING[26163]: loader.c:393 load_dynamic_module: Error loading module ‘res_fax.so’: /usr/lib/asterisk/modules/res_fax.so: undefined symbol: ao2_unlock
[Apr 7 11:33:18] WARNING[26163]: loader.c:770 load_resource: Module ‘res_fax.so’ could not be loaded.

First i tought i downloaded the module for the wrong cpu but no matter what cpu i choose on the Download Selector, its allways the same res_fax file it presents: downloads.digium.com/pub/telepho … _32.tar.gz.

I have checked the permissions on the file, but they are the same owner and mod as the other module files.

Does anyone know how to fix this?


Try to do the follow:

Look if insite /etc/asterisk/ there are two files called res_fax.conf and res_fax_digium.conf. If these files don’t exist, create they. If these files exist, take a look inside they.
Normaly, new Asterisk box FreePBX based, put these files at /etc/asterisk/ with one #include inside each file and don’t create these #include. If you found an “#include” inside these two files and don’t found the include files inside /etc/asterisk, create these #include files insite /etc/asterisk with the command “touch”.
After that, try to reload theses modules.
Don’t forget to come back here and tell me if this fix your problem.

Best regards,


The files didnt exist in /etc/asterisk.
Creating them didnt help, still get the same error.



I too have this problem.
The decision is available?

Best regards,

Do you have all shared libraries?

# ldd /usr/lib/asterisk/modules/res_fax.so


ldd /usr/lib/asterisk/modules/res_fax.so

    linux-gate.so.1 =>  (0x00c54000)
    libc.so.6 => /lib/libc.so.6 (0x00704000)
    /lib/ld-linux.so.2 (0x00518000)

Im trying to get fax to email to work aswell, is there a detail howto on how to set this up ?

I have : FreePBX & Asterisk (Ver. on CentOS 5.4

Did any of you get asterisk’s fax to work with trixbox? I’m trying this and having some difficulty.