Extensions.conf - syntax enhancement suggestion

Along the some line of thinking as the “n” to avoid renumbering, let me make this suggestion. Current syntax is:

exten => 101,1,Answer( )
exten => 101,n,Wait,1
exten => 101,n,Playback(greeting)
exten => 101,n(startover),Background(instructions)
exten => 101,n,WaitExten

Why not do this?

exten => 101,1,Answer( )
next => Wait,1
next => Playback(greeting)
next => (startover) ,Background(instructions)
next => WaitExten

The idea is that the “next” term is like “exten” but it copies the extension from the last exten command and assumes “n” to increment the priority count.

Furthermore, why not allow multiple command on the same line?

exten => 101,1,Answer( )|Wait(1)|Playback(greeting)

care to share how a GotoIf would work in your example ? personally i dislike the ‘n’ priority syntax … much prefer to see the numbers.

You aren’t using named labels in your goto?

no, numbers are easier to spell :smiley: