Error calls towards trunk SIP


#1

[11.30.40] Ursula: Hello,
The problem is very simple. I have always used the two trunk sip on my asterisk 1.6. Usually I use them for a demo with clients, and in order to activate them on development machines. Since yesterday they doesn’t work anymore.
If in CLI I write SIP show peers, I see them correctly as UP, but if I try to call by using them I see the following message:
Error calls towards trunk SIP

Executing [XXXXXXXX@from-pstn:1] Dial(“DAHDI/9-1”, “SIP/lh01/802”) in new stack
== Using SIP RTP CoS mark 5
== Using SIP VRTP CoS mark 6
– Couldn’t call lh01/802
== Everyone is busy/congested at this time (0:0/0/0)
– Executing [XXXXXXXXX@from-pstn:2] Hangup(“DAHDI/9-1”, “”) in new stack
== Spawn extension (from-pstn, XXXXXXXXX2, 2) exited non-zero on ‘DAHDI/9-1’
– Hungup ‘DAHDI/9-1’

lh01 is trunk name
802 is the internal
XXXX are for privacy

Of course I rebooted the machine several times and I have not made ​​any installation and / or updates for at least 6 months

Does anyone have any ideas?

greetings
David


#2

what is output of 1. sip show peers 2. sip show peer ih01


#3

Tnx for replay, tomorrow morning i’ll post the 2 output


#4

This is the End of sip show peers

627/627 (Unspecified) D N 0 Unmonitored
628/628 10.0.15.97 D N 5060 Unmonitored
886/886 (Unspecified) D N 5060 Unmonitored
887/887 192.168.1.174 D N 5060 Unmonitored
980/980 10.7.27.185 D N 5060 Unmonitored
981/981 10.7.27.185 D N 5060 Unmonitored
982/982 10.7.27.185 D N 5060 Unmonitored
983/983 10.7.27.185 D N 5060 Unmonitored
984/984 10.7.27.185 D N 5060 Unmonitored
985/985 10.7.27.185 D N 5060 Unmonitored
986/986 10.7.27.185 D N 5060 Unmonitored
987/987 10.7.27.185 D N 5060 Unmonitored
988/988 10.7.27.185 D N 5060 Unmonitored
989/989 10.7.27.185 D N 5060 Unmonitored
990/990 10.7.27.185 D N 5060 Unmonitored
991/991 10.7.27.185 D N 5060 Unmonitored
992/992 10.7.27.185 D N 5060 Unmonitored
993/993 10.7.27.185 D N 5060 Unmonitored
994/994 10.7.27.185 D N 5060 Unmonitored
995/995 10.7.27.185 D N 5060 Unmonitored
996/996 10.7.27.185 D N 5060 Unmonitored
997/997 10.7.27.185 D N 5060 Unmonitored
998/998 10.7.27.185 D N 5060 Unmonitored
999/999 10.7.27.185 D N 5060 Unmonitored
gatewaybri0 (Unspecified) D 5060 Unmonitored
lh01/lh01 10.7.34.66 D 5060 Unmonitored
pbx/pbx 192.168.1.253 D 5060 Unmonitored

This si sip show peer lh01

Dynamic : Yes
Callerid : “” <>
MaxCallBR : 384 kbps
Expire : 60
Insecure : port,invite
Nat : RFC3581
ACL : No
T.38 support : No
T.38 EC mode : Unknown
T.38 MaxDtgrm: -1
DirectMedia : Yes
PromiscRedir : No
User=Phone : No
Video Support: Yes
Text Support : No
Ign SDP ver : No
Trust RPID : No
Send RPID : No
Subscriptions: Yes
Overlap dial : No
Forward Loop : Yes
DTMFmode : rfc2833
Timer T1 : 500
Timer B : 32000
ToHost :
Addr->IP : 10.7.34.66 Port 5060
Defaddr->IP : 0.0.0.0 Port 5060
Prim.Transp. : UDP
Allowed.Trsp : UDP
Def. Username: lh01
SIP Options : (none)
Codecs : 0x0 (nothing)
Codec Order : (none)
Auto-Framing : No
100 on REG : No
Status : Unmonitored
Useragent :
Reg. Contact : sip:lh01@10.7.34.66:5060;rinstance=427952aea2eeb15a;transport=UDP
Qualify Freq : 60000 ms
Sess-Timers : Accept
Sess-Refresh : uas
Sess-Expires : 120 secs
Min-Sess : 90 secs
Parkinglot :

This is thw sip.conf

[general]
;realm = asterisk
videosupport=yes
allow = g729,alaw,ulaw,g723,h263,gsm
disallow = all
limitonpeers=yes
rtptimeout = 600
session-timers=accept
session-expires=120
session-minse=90
session-refresher=uas
rtptimeout=600
notifyringing = yes
notifyhold = yes
callcounter = yes
allowsubscribe=yes
subscribecontext = from-pstn
allowoverlap = no
port = 5060
bindaddr = 0.0.0.0
language=it

register=>pbx:pbx@192.168.1.253/pbx
register=>test:test@10.7.34.66

[lh01]
username=lh01
type=friend
secret=test
insecure=invite,port
host=dynamic
context=from-pstn


#5

No codecs, presumably because of the disallow after the allow.

Also, 60 seconds is rather short for a re-register interval, and it is possible that they other side might not go that low.


#6

thank’s for reply…but i don’t understund ho to solve it…

must I commit disallow=all?

Where Can I increase the expiration time?


#7

I solved it!!!

I’ve change disallow=all before allow=g729,alaw,ulaw,g723,h263,gsm

Thank’s at all

Now remain how to increase the expiration time


#8

The short register timeout may actually be set at the other end.


#9

try adding
register=300
to the sip.conf entry. it is presently not specified so the default is 60.


#10

The default may be OK. It just felt a bit aggressive to me. I would leave it alone if it is working now.