E&M Trunks and Asterisk


#1

I’m trying to get asterisk working with a fractionalized T1 of E&M trunks, however I get the following error when trying to run ztcfg… Any Ideas?

Thanks in advance…
-Jeff

Zaptel Configuration

SPAN 1: ESF/B8ZS Build-out: 0 db (CSU)/0-133 feet (DSX-1)

Channel map:

Channel 01: E & M (Default) (Slaves: 01)
Channel 02: E & M (Default) (Slaves: 02)
Channel 03: E & M (Default) (Slaves: 03)
Channel 04: E & M (Default) (Slaves: 04)

4 channels configured.

ZT_SPANCONFIG failed on span 1: Invalid argument (22)

My /etc/zaptel.conf file is as follows:
loadzone=us
defaultzone=us
span=1,1,0,esf,b8zs
e&m=1-4


#2

hmmmm, everything looks good (we’re running E&M signalling on our T’s, although we have either 3 or 4 full T’s per server).

double check to make sure you don’t have any extra spaces after any of the config lines, and that there are no extra carriage returns at the end of the zaptel file - that caused us issues one time.


#3

aha, found the problem. from voip-info:

If you have a fractional-E1 PRI, then less than the full 30 channels will be active. However, all channels should be configured in zaptel.conf as shown above.

i know we’re talking about fundamentally different technology, but i’d venture to guess that the system is going to be looking for 24 channels per span.

it’s zapata.conf that actually configures the channels, whereas zaptel.conf configures the entire T1…it kinda makes sense.

i bet if you change your channel span to 1-24 it will work.


#4

I think I figured it out… (atleast that error isn’t shown anymore :smile: Thanks for your help and the quick reply.

It was that I have 2 cards in there a TE100P and a TDM04B the module for the TDM04B was interfering some how, so I just disabled it for now…

Now all I have to do is figure out why I’m getting no debug info and a fast busy signal when trying to call in on one of these lines.