DTMF timing issue

Hello community,

I’m facing a weird DTMF issue :
When the same digits are sent in a row, the called party hears one long tone, instead of n tones for each digit.

For instance, i’m using AMI to Originate a call and bridge it to the following context :

exten => s,1,NoOp(paging)
;exten => s,n,SIPDtmfMode(inband)
exten => s,n,Wait(3)
exten => s,n,SendDTMF(666*)
exten => s,n,Wait(6)
exten => s,n,Playback(hello-world)
exten => s,n,Hangup()

The calling party hears only one long ‘6’ tone, pause and then ‘*’ overlapping with the ‘hello-world’.
Whereas, when i SendDTMF(123) for instance, there is no issue.

I tried to use the timing options of SendDTMF(), for instance

exten => s,n,SendDTMF(666*,500,500) without any more luck.

As you may have seen, i have already tried to change the dtmf mode to inband (i’m using G711), info and rfc2833, with no luck.
I also tried to call SendDTMF() for each digit and use Wait() between each call in order to time this out, with no luck. Also with the ‘w’ option in SendDTMF() to time this out, no luck :frowning:

I also tried using the PlayTones() application specifying the DTMF frequency PlayTones(770+1477/500), without any more luck.
Somehow, when i try to time this out with Wait(), the wait is ignored :

exten => s,n,PlayTones(770+1477/500)
exten => s,n,Wait(10)
exten => s,n,PlayTones(770+1477/500)

I just hear a long ‘6’ tone, without any pause…

If I try, from my softphone (Zoiper), to call in this number and manually enter the DTMF, the remote end receive the proper DTMF with the proper timing. Please note that i’m using the same provider for both my softphone and the Originate command.


[root@newpage asterisk-11.2.1]# asterisk -rx 'core show version'
Asterisk 11.2.1 built by root @ newpage.local on a x86_64 running Linux on 2013-04-17 19:09:08 UTC
Asterisk ending (0).
[root@newpage asterisk-11.2.1]# uname -a
Linux newpage.local 2.6.32-358.0.1.el6.x86_64 #1 SMP Wed Feb 27 06:06:45 UTC 2013 x86_64 x86_64 x86_64 GNU/Linux
[root@newpage asterisk-11.2.1]# cat /etc/redhat-release
CentOS release 6.4 (Final

Any input would be much appreciated