DTMF not working in G729 codec


i have the asterisk 1.2.4 installed with tdm cards. i use polycom ip phone it is worrking with ulaw, and the same dtmf is not acceptable in when i use g729 … i shall be thankful, if you can guide to resolve the issue?

What DTMF you are using?
I’ve read that you have to pay for using the G.729A, maybe it has something to do with that

i use rfc2833 as the dtmf mode and i paid the for g729 licence and i got it and installed now… it works fine except the dtmf problem…


There is a know problem trying to use DTMF in-band with G729. You may want to try rfc2833. In sip.conf under general add:


It may help.


i tried it in sip.conf… No progress in issues solved.

Any help may be appreciated!!

have you turned up the debugging level to see if you can see the dtmf coming through asterisk? If so, have you tried a tcpdump and examined it in ethereal to see if the polycom is sending the dtmf digits?


if you are using an old polycom firmware there are issues…
upgrade to the 1.5.x or 1.6.x SIP Apps and have at it…

i have upgraded my asterisk version from 1.2.4 to it solved all our issues.

thank you very much for your help.

I know that with my voip provider, the dtmf payload must be 96 instead of the 100 or 110 that is set in the asterisk@home version. I have been trying to find a way to change to the 96 payload, but haven’t found a solution yet.

Check and see if you might be running into the same issue.


I have same problem.

A partial solution is changed dtmfmode = auto.

But you call to other pbx (some) and you receive sip messages (INVITE), when the other PBX transfer to its internal extensions.

I have the same problem,
do you find any solution?

As you haven’t actually described your problem, I have to work from the subject line. G.729 is speech codec. DTMF must either be sent out of band or using an audio codec.

If you are actually sending it out of band, please provide details of the method and that the peer is also using that method.