DTMF not being sent

Hello folks,

I just setup PBX in a Flash (Asterisk 11 + FPBX) on an ec2 instance and the send dtmf portion of my dialplans(context) seem to not be getting to the other end. I’m using Asterisk Java to originate the call but I don’t believe the problem lies there. When I call with a softphone, the IVR on the other side recognizes my input. This problem only persist when I originate a call with a dialplan.

I’ve searched and researched everything I can all and nothing seems to directly address my issue or provide a solution.

I have a local AsteriskNOW (Asterisk 1.6.2 + FPBX) running and everything is fine there. The trunk setting on the ec2 and the local servers are identical. The dialplans in extension.conf are also identical. I’m using voipms as a provider on both system with 2 different accounts and asteriskjava to execute both calls so I really do not know why one works and the other doesn’t.

I enabled dtmf logging but that doesn’t seem to write anything to the logs(that I can see) when the call is being executed from the dialplan. If I call from a softphone I can see the dtmf’s I press being logged.

I’ve tried changing dtmfmode to inband, rfc2833, info - to no avail.
Ive added : relaxdtmf=yes and rfc2833compensate=yes — They dont seem to help either.

I’ve recorded the call and when listening to the out audio (with dtmf=inband) I can actually hear the tones been sent, but the IVR I’m calling does not recognize it or act to it.

Note: I’m calling the same IVR on both the local and ec2 server and the local version works with whatever dtmfmode I chose.

Any help would be much appreciated.


I shouldve added its Asterisk 11.2.1 and FreePBX

It seems the tones are being sents way too fast and nothing I tried slows them down.

Ive tried changing it to



SendDTMF(${digits},200) doesnt seem to make any difference in the speed each digit is sent.

Resolved - turned out using rfc2833 / info as dtmfmode does work sometimes if I add a long enough delay between digits, it just takes longer to register for some reason which threw off the timing of my dialplan.